Support ticket #2558753, no response in 12+ hours

hello,
our site is really messed up due to some “odd” caching issues. I’m thinking it is due to OLD or no longer used IPs (or something else) in the DNS? I only know a little but assuming support could quickly correct/fix or make what changes needed.

IT seems to me, there are 2 sets of IPs (one is the current server and not sure what the other IP is).
My server support told me to replace 1 set of IPs, which it started working, but then shortly later, a LOT of weird caching problems started happening.

After going live, I see that turning on Development Mode, actually fixes the site (so it all loads correctly), but every few hours… that setting gets turned OFF? who or what is turning it off?

I didn’t expect support to take forever to reply to the ticket?

thanks for any help

The two sites look identical to me, looks like the only change was development mode. Here’s what development mode disables: Development Mode · Cloudflare Cache (CDN) docs Have you tried purging your cache and turning off development mode?

thanks Sean,

note: the IP ending in .152 is the new hosting server.

As far as the other IPs… I don’t know anything about them.

The confusing thing you said, “the two sites”. What are the two sites?
there is only 1 site.

Oh, are you saying, in the ticket… the dev site and the live site?
Yes, BUT THAT is ONLY because Dev Mode is on. If dev mode turns off… the live site gets ugly, displays old deleted content and the Wordpress admin pages do not work.

Thanks for helping…
what needs to change?

PS. You saw that one error page, which came up in the WP Admin pages… “how is an IP being blocked by clouldflare?”

I updated the ticket… there is a clarification question. thanks.

OR does someone know if
172.67.136.169
should NEVER be added in DNS as a www record?

PS. apparently, that IP was added prior? Assuming that is the issue.

That’s a Cloudflare IP address, so, no

May I ask which Cloudflare plan are you using? :thinking:

Did you used WPEngine or SiteGround, or some other 3rd-party web hosting/service provider before?

Was Cloudflare used since before or?

Some users use eZoic and similar service integrators too.

Contact web hosting provider to flush & clear the origin host cache.

Is there any caching plugin for WordPress active?

Kindly, may I ask you to check out what option have you got selected by navigating to the Cloudflare dashboard → Caching → Configuration → find section “Browser Cache TTL” and make sure the selected option from the dropdown menu is “Respect Existing Headers”.

Furthermore, from the same menu, click on the blue button saying “Purge Everything” to flush the cache at Cloudflare Edge, just in case.

Wait for a minute or two.

Refresh a page in your Web browser, otherwise try clearing your Web browser cache or use a different Web browser to test out again.

May I ask in which way?
Do you see the correct website again when it’s enabled?

Maybe the SSL certificate wasn’t being created at your new hosting yet for your domain name.

Before moving to Cloudflare, was your Website working over HTTPS connection?

I’d suggest you to whitelist your origin host / server / hosting IP address by navigating to the Security → WAF → Tools → IP Access Rules with the action “allow” for your Website and try again.

It happens due to the WordPress using HTTP/1.0 and empty user-agent, therefore while executing WP-Cron or some other related JSON/REST API request.

As far as this one IP belongs to the Cloudflare network (ASN).
When doing a DNS lookup of a proxied (:orange: cloud) hostname or a domain using Cloudflare, the returned IPv4, and IPv6 addresses would likely show as being in the US.

At the DNS tab of CF dashboard for your domain, you should use either your origin host/server IP or a temporary IP like 192.0.2.1 if you’re using Cloudflare Workers, etc.

However, at least in the end of all, I’d suggest you to temporary enable the “Pause Cloudflare for this site” option from the bottom-right corner of the CF dashboard → Overview.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.