Support for node.js package-lock v2 syntax

Newer versions of node.js use an updated and optimized version of the package-lock.json that is not completely compatible with LTS parser, this results in the impossibility to deploy some websites using package-lock v2 syntax in Cloudflare Pages.

Is there any plan to support syntax v2, maybe letting users choose between npm LTS version and latest available one?

You can already choose your node version with the NODE_VERSION environment variable :slight_smile:

1 Like

Thank you, just tried and it works perfectly

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.