Support for emoji characters in custom domain for pages?

I have an emoji website , this isn’t it but lets assume it was xn–

when i setup pages to have, and then i try to CNAME @ or root to it, i just get errors… what should I do?

if you try to do Add a custom domain to, even if i own it and the DNS is ON cloudflare, it says “please enter a custom domain” if i paste in the original emoji. if instead i put the xn-- version of the domain it will go to the next screen where it claims it will update DNS, but then it gives me:
An unknown error occured. Contact your account team or Cloudflare support: (Code: 8000000)

If i try to update the DNS manually, it will take in the DNS settings to point the CNAME root to, but then going to the DNS address just results in a 522 error page, where it shows issue with the host.

What should I do ?

What’s the I can’t find this one

oh its actually xn–
Trying to connect

This is as far as you can get… then the activate domain button triggers that red warning. I tried just setting the DNS manually- turned off proxy (because sometimes that can do bizarre things)… I tried to remove the A records so that is the only root CNAME… still getting 522. I assume its because it’s an emoji domain because I’ve never had issues before but I’m lost on next steps…

You should be good now.

1 Like

Oh wow, now it’s all good! Thank you so much!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.