SuperAdmin errors and misnamed worker addresses

I recently renamed my account and all the data within it to match my corporation. Upon doing so, my worker address still shows the old base address (never created one before) so I wanted to create one, and I’d prefer the new address.

Secondary to that, I needed to be able to give Cloudflare permission to edit my account, and when I choose an expiry it says I’m not a SuperAdmin but I’m the only one on the account, so I should be.

Any help or understanding would be greatly appreciated.

Thanks!

If you’re referring to the default *.worker.dev subdomain, you can change it as documented here and in the screenshot below.

Note that you may not see the right column if you don’t have any Workers created. If this is the case, simply create the default “Hello World” Worker, and, afterwards, should have the option on the right to change your subdomain.

1 Like