Super slow 'A' record DDNS when Proxy enabled?


#1

Hey all

So, I setup a DDNS for one of my domains to point to my home IP, and use a small script to use the CF API to keep it updated.

the ‘A’ record has the hostname, the TTL, and the value is my home IP.

so it looks something like this: foobar.mydomain.com 2minutes 12.12.12.12

Now, when I set the record to “DNS Only”, connecting to foobar.mydomain.com works great; redirects to my home IP, things are speedy. However, when I click the little cloud to turn it orange (DNS and HTTP Proxy (CDN)), it’ll still connect, but it’s DOG SLOW, and even sometimes times out before finishing loading a page, or even doesn’t completely load all the CSS for the page. I’d like to be able to use the CDN proxy as well.

Any idea why?

TIA


#2

I’d experiment with a Page Rule that matches *foobar.mydomain.com* and set it to Disable a bunch of stuff. If that speeds it up, start turning stuff back on.

By the way, do your server logs at home show anything?


#3

Thanks @sdayman, I gave that a try, but unfortunately it didn’t seem to have any positive effect.

Re: home server logs, so far I’m only using it to connect to my router, and in the router I don’t see anything strange showing in the router logs when I enable the proxy.


#4

Hi @stardogg - I saw that you sent in a ticket as well, but since it points back to the dummy info here it’s hard for them to troubleshoot. Can you reply with specifics on the ticket so one of the support engineers can advise?


#5

Hi Ryan,

Done. =)


#6

This topic was automatically closed after 14 days. New replies are no longer allowed.