Suddenly mails not getting sent from mail server

I use a PHP script to send group emails to all my customers. Everything was working fine till 9th April 2021. But, suddenly from 10th April Night, the mails are not getting delivered to my customers. I haven’t changed any code or DNS record. With the same codes and DNS records, everything was working just fine a day ago.

My website is hosted on Godaddy and the Nameservers are on Cloudflare. I have raised a support ticket with Cloudflare for which I am yet to get a response. I contacted Godaddy support team also, and they asked me to change the DNS record “A - www - @” to “CNAME - www - @”. I did that but it’s still not working.

I also changed the Proxy mode for the DNS record “A - mail - XXX.XX.XX.XX” to DNS only by taking references from Cloudflare help articles but no luck with that also. However, it was working fine with this record being proxied.

Also, I am able to send and receive emails using the Windows 10 Mail app. Cpanel created email: [email protected]

Any help will be highly appreciated. My mail going out from the website are completely halted! Please help.

Your server certificate expired two months ago, you should fix that first.

As I have mentioned everything was working fine till 9th April so I believe the certificate issue is not doing anything here.

The certificate is not mail related but it still is something you need to fix as you have an insecure setup right now.

That I know and will take care. Any help for the asked question will be highly appreciated.


I believe you might need to update PHP to use TLS 1.2
At work we had a MS Exchange server stop working on phones because old TLS versions became deprecated and after updating the server to TLS 1.2 it started working… Just a thought

@mike6715b below is my web server info:

PHP version: 7.3.6

I am afraid if this is a PHP or server issue the forum is the wrong place and you’d need to ask at a more appropriate forum, as the forum here is only for Cloudflare related issues, which this does not seem to be as Cloudflare does not handle email at all.

1 Like

@sandro This is not a PHP or server issue. Please don’t create confusion here if you don’t have the solution. I have explained that the same code and configuration was working completely fine just one day back. So, definitely, there is some issue from Cloudflare end. I posted the PHP version to clear that only. If you don’t have the solution then please don’t mislead the audience also. Thanks for your understanding.

Well, Cloudflare does not handle emails and, unless you can point to something specifically Cloudflare related, it cannot be Cloudflare as email is not involved at all and that’s where my previous point comes in, such a topic would be off-topic here.

Plus, your certificate is still unfixed.

1 Like

@sandro A child would have even understood by now that the same Code/Configurations was working completely fine just a day back and I haven’t modified anything. But, still if you want to keep dragging it then I can’t help it.

Not sure I appreciate your tone. It’s impossible to say what the issue is but as I explained more than once, Cloudflare is not handling email. If your server cannot send emails that will be something on your server and that’s what you need to debug first and a topic which is off-topic for here. If, then, you can point out a specific Cloudflare related issue, you are most welcome to ask for help here, but until then general server administration is unfortunately off-topic. The forum is intended for Cloudflare related questions, not if your server cannot send emails for whatever unknown reason, there are better and more appropriate forums out there.


Anything in the log files?

That is the right way.

Track email deliverability, does it have any warnings/errors?

Does it use a hostname or to sent out the e-mails?

  • or somehow a true web server’s IP address behind your proxied domain which is nowhere listed as “safe” or “allowed” to sent them out …

If it’s using, that is wrong one. Should go with when sending out (and receiving as well).

Your IP address (of an A mail hostname) has got the PTR, but the FcRDNS record is not the same as, so it should still need no fix to have the mail hostname as return, but it could be one of the reasons why other E-mail MTA’s could possibly drop or reject the e-mail comming from your IP (I am just assuming).

  • or it is considered as a SPAM?

Also, regarding cPanel, do you have an AutoSSL for your hostname added?
Furthermore, while using PHP, do you simple mail() function or PHPMailer as already stated?

Maybe you are missing the TXT records for SPF and/or DKIM validation?

Maybe your PHP script or server is using wrong port to sent out the mails?

And as already stated, no SSL certificate.

Not sure, because you already created an A mail record and pointed it to your email hosting/server IP address having it on :grey: cloud (DNS only).
Also to note here, Cloudflare by defalut does not proxy an e-mail traffic on known ports like 25, 110, 465, 587, 143, 995, 993.

If using cPanel PHP manager/selector, check for the selected/checked options under PHP settings (maybe mail is not enabled) or creating an php file like phpinfo.php which contains <?php phpinfo();?>.

Moreover, maybe in your cPanel GoDaddy e-mail destination is setup to go to instead of going to (because your main domain is being proxied via Cloudflare now :orange: records)?
Can you re-check that in cPanel e-mail destination where it actually goes?

GoDaddy SMTP works over 25, 587 and even port 80 (not referring here to an Webmail to witch user connects via Web browser, if so, to unsecured Webmail) - maybe that’s the case, if it goes out through the port 80?

If you have an early mail which you sent out, can you re-check the mail headers? Were they sent over your hosting IP address or over some Workspace e-mail? -> port 25? -> port 80? -> port 25? -> port 25?


What about GoDaddy help center?:

Otherwise, it is actually out of the scope of CF community forums as already posted above:


This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.