Successful Argo Tunnel & cPanel Setup, anyone?

Has anyone been able to make a successful set up with the control panel cPanel and Argo Tunnel? If so, how did you make it work?

Personally experimenting right now trying to get Argo Tunnel running for a singular domain inside created inside of my cPanel/WHM install here but can’t really get past some small errors blocking me from reaching the sites content itself.

What errors? If you give it the correct hostname and the correct port there shouldn’t be issues.

Running the following command to launch my Argo Tunnel:
cloudflared tunnel --hostname domain.tld --url http://localhost:80

After giving it a bit to let the route propagate I receive the typical cPanel sorry screen giving you a couple of different possible reasons to the issue. Them being the following:

  • The IP address has changed.
  • There has been a server misconfiguration.
  • The site may have moved to a different server.

These reasons also has more descriptive descriptions below them. Here is a image URL to what the screen looks like.

Not too sure if this is caused by cPanel or LiteSpeed Web Server, if not both maybe.

It seems like the website is not at that address. Maybe it’s not allowing you to access it via localhost.

Two options:

  1. Does using the public IP of the server instead of localhost work?
  2. Try doing a curl -I http://localhost from the command line of the server.
1 Like

@matteo you’re a legend!

Using localhost doesn’t seem to be a valid solution when running it in such a use as I am. Replacing localhost with the public IP and removing the port solves the issue.

Thank you!

2 Likes

Happy it was fixed!

The port is redundant in this case, but removing it wasn’t the actual solution. With http you need to specific a port if it’s not 80, with https it should be specified only if not 443 as they are the defaults.

1 Like

It took me a moment to realize—while Argo Tunnel is now protecting my domain it has made my WHM and cPanel inaccessible. All it does is give me a 404-error for whatever reasons.

Trying to figureout why this is happening, doesn’t make a lot of sense to me, at least with my amount of knowledge with Argo Tunnel.

It shouldn’t be though. Argo Tunnel is a client accessing the website, there is not even a port used on the device. Maybe cPanel is on a different port?

PS: is it inaccessible from Argo Tunnel or at all?

AFAIK, cPanel’s WHM admin side should be on 2086/2087 for non-https and https and cPanel client side is on port 2082/2083 for non-https and https.

1 Like

Inaccessible from Argo Tunnel. Can access WHM and cPanel with Argo Tunnel disabled.

When it comes to the ports, @eva2000 is correct on that.

You need a new tunnel to that port, Argo Tunnel works only on the port you specified. Create a new tunnel pointing to it and it will work, it requires a different subdomain though.

If I were to do the following commands, it should work you say?
cloudflared tunnel --hostname sub.domain.tld --url http://public-ip:2082
cloudflared tunnel --hostname sub.domain.tld --url http://public-ip:2083

Only one is needed, being local host using only the http port would work just fine.

PS: you obviously still need the other one we got working before.