Subdomains without the "cloud" are updating http to https

Hi,
I have a dynv6 ddns and my problem is when I create a CNAME subdomain “let’s call it x.domain.dev” without “cloud” enabled (and pointing to the dynv6 address of course) http is automatically updated to https. And nothing helps, not if I disable SSL mode or if I create a page rule that disables SSL specifically for that subdomain. But before I had a dynv6 (i.e. a ddns with IPv4) directly on Cloudflare with the API it worked without any problems. So when I created a subdomain without the “cloud”, http worked with no problems.

I’ve trief this so far:

  • Rule with: “Disable Security, SSL → Off, Disable Apps, Disable Performance”
  • SSL/TLS Settings: SSL to Off, Always Use HTTPS → Off, HSTS → Off, Automatic HTTPS Rewrites → Off, Disable Universal SSL

I hope anyone can help me.

.dev is configured for HSTS by the registry, so clients following HSTS (e.g. browsers) will always use HTTPS. You cannot downgrade to HTTP.

1 Like

Okay but why it worked before?

It didn’t. The registry enforces HTTPS.

If you need HTTP, you can’t use .dev.

This isn’t true it worked before.

Then you need to contact your browser vendor as their HSTS implementation does not work.

This topic was automatically closed 4 hours after the last reply. New replies are no longer allowed.