Subdomains ssl authorization

#1

Goodday,
I have created a site and i have authorized Cloudflares universal certificate for it.
Site url being http://ttunezmusic.cf
But now i have also created subdomains to go along with it. The issue still remains now, how to do i configure ssl certificates for the subdomains as well because i cant just have the site running on the subdomains without site security. Please i am fairly new into all these coding html, php stuff. Even most of the stuff on cloudflare is quite tough for me to understand. Please Kindly break them down to the simplest manner in which i could understand it please.
Thank you.

Subdomains being; http://m.ttunezmusic.cf, http://policies.ttunezmusic.cf, http://contact.ttunezmusic.cf

0 Likes

SSL subdomain setup
#2

Those are all covered by the Universal SSL Certificate. This certificate will cover example.com and *.example.com. The * can be ‘www’ or ‘m’ or ‘contact’ or any other single “word” subdomain.

If that subdomain is set to :orange:, it can use the Universal SSL Certificate.

Note: *.example.com will not cover www.sub.example.com (that would need to be *.*.example.com, which does not exist in Universal SSL).

1 Like

#3

Hello, Please i do not understand
the wildcard says *.ttunezmusic.cf
And all the subdomains are set. I do not still get it.

You could confirm http://ttunezmusic.cf and http://m.ttunezmusic.cf

0 Likes

#4

You “m” subdomain is not set to :orange: in DNS. Go to the DNS page here and click on the :grey: icon to make it :orange:

0 Likes

#5

Okay i have done that, would that make it use the universal ssl certificate from cloudflare. Please that is my question.
And also i usually notice all this sites using cloudflares common name to purchase comodo certificates, how is that done.
Thanks for your understanding tho

0 Likes

#6

Good, that is using Universal SSL now.

Cloudflare uses Comodo as one source of TLS/SSL certificates. There are others as well. They are all just as good as the others.

0 Likes

#7

Okay, its using universal ssl but then it is not reflecting in the web browsers as secured, how come?

And also, please how is one about to get a comodo certificate using cloudflare.

0 Likes

#8

Your “m” subdomain is showing a secure.

As for a Comodo certificate…you get whichever one Cloudflare is using at the moment. As I said, they’re all just as good.

0 Likes

#9

Okay i have been able to see that but to do you know when i checked mine, it showed me lets Encrypt X3 certificate and plus it is not redirecting to https automatically, how do i change that for it to redirect to https automatically

0 Likes

#10

It sounds like you’re going direct to your server. You probably have to wait for your local DNS to refresh.

0 Likes

#12

My apologies for the constant disturbance but then i want to set the universal ssl for my subdomains again but this time on another site
https://thetribeng.cf. For multiple subdomains but i want to test one first. http://m.thetribeng.cf
I have set the traffic to the hostname to go through cloudflare for the subdomain but now it is telling me that the site isnt secure when i try to load the site through https
Please what can i possibly do at the point

the first site i tried it on worked very fine until this point: https://ttunezmusic.cf & https://m.ttunezmusic.cf

Please a quick response would be highly appreciated. Thank You

0 Likes

#13

All these load over HTTPS for me,

shows a directory listing, but loads securely, any issue there seems to be with your host. All seem to be working correctly with Cloudflare.

0 Likes

#14

My issue is with the sites ssl certificates
It still shows not secured for the subdomain https://m.thetribeng.cf while the main domain, https://thetribeng.cf works prefectly. How do i solve that

0 Likes

#15

Showed secure for me, try clearing your cache.

0 Likes

#16

This whole thing just confuses me. Kindly send a picture of the site showing secured please
Let me confirm

0 Likes

#17

Something has since changed. It worked correctly over HTTPS before. Now:


This site can’t be reached

m.thetribeng.cf ’s server IP address could not be found.

DNS_PROBE_FINISHED_NXDOMAIN


0 Likes

#18

Try and reload it, my bad, i caused that

0 Likes

#19

0 Likes

#20

Okay thank you
One more thing please kindly help me check this one out please. http://tv.thetribeng.cf May i know why it says page not found

0 Likes

#21

I get the same as

It shows as secure, but only a directory listing. There don’t appear to be any files there with the host. It works correctly with Cloudflare SSL though.

0 Likes