Subdomains show but not main website

I solved the following problem by changing FLEXIBLE SSL (from instructions) to FULL SSL. 10 hours I’ll never get back. The glass is always half full and leaking. >>>>>>>>

SSL not completed but cards (subdomain) and addons (subdomain) do display as websites. The main website (simple WP site to work on) shows “too many redirects”. I copied the long list of permissions from CF into one of the .htaccess files, but that didn’t help.

businesscardleads dot com has an SSL certificate (free from the hosting company) so I don’t need another one. A cloud is showing, but it may be picking that up from the host.

I don’t think I need to wait until the SSLs from CF show to get the main site to display. Need to fix this. Spent way too many hours already.

Also, the MX file has an warning that the IP address may be seen. Not sure what to do about that.

Hi @artderfall

Did you follow Cloudflare’s instructions for setting up your site, as this shouldn’t have been the case there.

Glad you got it sorted, anyway.


With a valid cert on your server, you may want to even switch to Full (strict) for increased security.

This topic was automatically closed after 31 days. New replies are no longer allowed.