Subdomains not working when cloudflare option is turned on


#1

Hi,

I just recently turned on CloudFlare for my main website speestaffing.net . I have a subdomain and added the A record in the CloudFlare DNS section.

designs.speedstaffing.net

but when I turn on to use cloudflare (orange cloud) the subdomain page would not open or work.


#2

I’m seeing A LOT of A records on your account, and some of them appear to be duplicating others (but with www. first).

Can you describe what exactly you are trying to do, so that we can hopefully explain what should be done. Do you want all traffic to have “www”? Do you want all of the A records to just redirect to designs.speedstaffing.net?


#3

I do want to have the subdomains pass through cloudflare cdn. As they have a separate Wordpress site hosted.

Thank you,
Syed Abbas


#4

With that many records I think it would be best to submit a ticket so we can openly discuss the specific details. We can come back after and provide a more generalized update that will benefit others. Can you submit a ticket to [email protected] with the details on desired behaviors? Specifically what points where and how you want it to display in the address bar.


#5

Hi,

I was able to resolve this with a little playing around. I deleted the subdomains and their directories on hostgator (my hosting service) and then recreated them. And it started working. but left the A records for the subdomains as they initially where in cloudflare DNS settings. So its resolved. Now one of the subdomain designs.speedstaffing.net passes though dns and http (orange cloudflare button) and is working fine.