Subdomains not working! (Godaddy site, cpanel hosting)

I had a domain (tyriad.com) on here that is registered with godaddy and used their cpanel hosting. I had multiple sites using subdomains that now all return DNS PROBE NX ERROR whenever I click them. Even though I have since removed my site from cloudfare entirely.

I added my site with the name records to cloudfare to utilize the free ssl certificate. I then realized the attached subdomains (which I have linked on the root site) now returned the DNS PROBE NX ERROR. I contacted godaddy support and they said something about the ssl lingering despite me completely deleting my site from cloudfare. I am just curious what I can do to fix this because that subdomain took me countless hours to put together for my business and I would be devastated to lose it. Godaddy asked me to ask cloudfare to help but now it looks like I can’t.

No matter what, if you offer a service, free of charge or paid, you need to offer human customer service. This is just poor all around customer relations. Some issues require personnel to fix. Anyways, I need help!

May I suggest looking into below article:

Kindly, re-check the DNS records at DNS tab on the Cloudflare dashboard for your domain.

Furthermore, I can try to access via HTTP, while for the HTTPS I receive SEC_ERROR_UNKNOWN_ISSUERThe original certificate provided by the web server is untrusted.

Looks to me as the SSL certificate is self-signed so far, using cPanel AutoSSL.

Kindly, fix your SSL certificate at the host origin / server first.

Maybe the domains weren’t being covered in the issued SSL certificate by the cPanel AutoSSL feature.

This could be a know issue that cPanel AutoSSL cannot be generated for the DNS records which are being proxied (:orange: cloud) - would generate the “self-signed” SSL certificate.

The workaround solution to this is to:

  1. Switch all of the DNS records from :orange: to :grey: cloud at the DNS tab on Cloudflare dashboard
  2. Therefore, run the AutoSSL on the cPanel
  3. When the SSL certificate is generated, switch them back from :grey: to :orange: cloud and make sure you select the Full (Strict) SSL option at the SSL/TLS tab

Free Universal SSL - yes.
In case you do not have an SSL certificate, you can use Cloudflare SSL, if so, kindly make sure you follow the instructions as follows on the below article to setup an SSL certificate using Cloudflare CA Origin Certificate:

That could be because:

  1. You are connecting directly to your host, meaning the DNS record www.tyriad.com and/or tyriad.com is not being proxied (:orange: cloud) and as far as I see the HTTP header server: Apache (should be cloudflare instead).
  2. You have temporarly enabled the Pause Cloudflare for this site option

Furthermore, I see the nameservers aren’t yet being pointed to Cloudflare:

QUESTION
tyriad.com. IN NS
ANSWER
tyriad.com. 3600 IN NS ns04.domaincontrol.com.
tyriad.com. 3600 IN NS ns03.domaincontrol.com.

Or the DNS propagation is in a process if you have recently changed them, which could usually take up to 24-48 hours to apply the needed changes.

Moreover, was your website working over HTTPS before moving to the Cloudflare?
May I also ask what SSL option have you got selected under SSL/TLS tab at Cloudflare dashboard for your domain?

Therefore, here is a way to re-check if you correctly setup the SSL for your domain with Cloudflare:

I am really sorry to hear that, but seems to me you were experiencing some DNS issues with your local DNS cache.

I am sure Cloudflare has got Support which you can reach by writing a ticket and contacting Cloudflare support due to your account and/or domain issue as follows below.

Also, you posted your issue here at Cloudflare Community Forums.

If you contacted Cloudflare Support, may I ask you to post your ticket number here?

We are here to troubleshoot and suggest what you have to do to fix your issue too.

2 Likes

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.