Subdomain with SSL off redirects too many times

Hello,
My domain is iranfilmplus.net coming with SSL. I have some subdomains such as tv.iranfilmplus.net, which I would like to have SSL OFF for them. So, in the page rule I have a rule: tv.iranfilmplus.net/* with SSL OFF.
For some years everything was okay. But as of last week I’m facing with a strange issue with the subdomain!

  1. If I use Google chrome (incognito mode), it gives me error “redirected you too many times”. (below screenshot, response header is with https)

  2. If I use Firefox, everything works correctly.

  3. Checking Redirect Checker | Check your Statuscode 301 vs 302, it doesn’t show any redirection loop.

  4. If I use VPN to change my IP, even in Google Chrome, it works correctly.

  5. I have 2 phones with the same WIFI and I test in incognito mode. In one of them, the site opens correctly, in the other one, it gives me error “redirected you too many times”.

  6. As for the phone which opens the site correctly, if I disconnect WIFI and connect to data, then it gives me error “redirected you too many times”.

Also, if I modify SSL/TLS to Flexible, Full or Strict, there is no difference in the above situation.
The URL Normalization setting are as below screenshot:

Can anyone help?

As you mentioned, there is no redirect sent by Cloudflare and as it is working with the other browsers, this will be something Chrome-specific. Maybe you have something cached (which your screenshot suggests). Check your HSTS settings as well.

It’s best to clarify this in a Chrome forum.

As for your question on the encryption mode, that should generally be only Full Strict. Overriding it with “Off” in your case certainly does work as exception however, as you specifically want HTTP.

Well, I just tested the site with Edge browser, and I can see that it shows me the same error of “too many redirects”.
The Non HTTP URL (http://tv.iranfilmplus.net) redirects to HTTPS based on 307 and then unlimited 301 redirection from https to http and vice versa (below screenshot).

So, it seems it is not just a Google Chrome issue.
I don’t undestand from where this 307 redirection comes from, while I don’t have it on my wordpress site!
It says “307 Internal Redirect (from disk cache)”

Isn’t it something related to the Cloudflare settings!!?

No, as already mentioned, that’s not Cloudflare related and Cloudflare does not send that redirect.

$ curl -I http://tv.iranfilmplus.net
HTTP/1.1 200 OK

I am afraid you really need to clarify this in a Chrome forum, as this is a Chrome issue and Edge is just a Chrome shell, but no proper browser.

I was curious about this one - it is Chrome specific behaviour (remember Edge is also based on Chrome):

https://chromestatus.com/feature/5485544526053376

Basically Chrome will redirect to HTTPS if a HTTPS records is present in DNS as part of this feature. We publish these records when you have Universal SSL enabled. You could disable it, but that would disable SSL for your entire website, so we wouldn’t recommend it. It’s best to just ensure your entire website works correctly over SSL.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.