Subdomain SSL NotWorking?


#1

We have a sub domain redirected to our affiliate program via CNAME, and have an SSL installed on our main site that works fine, but it wont work on the sub domain.

anyone have an idea why?


#2

What’s your SSL configuration like? Flexible, Full, etc… Are you using a page rule or ‘Always Use HTTPS’ on the Crypto tab of the Cloudflare dashboard?


#3

When you say subdomain do you mean something.example.com or something.somethingelse.example.com?

If it is the latter, you need to order a Dedicated SSL Certificate with Custom Hostnames. The default certificates support the naked domain (example.com) and one level of subdomain (*.example.com). They do not support multiple levels of wildcard. (*.*.example.com).


#4

Hello,

I have a similar issue, i have added a subdomain.mydomain.com in my cloudflare account.

And I get this error on browser error console:

WebSocket connection to ‘wss://subdomain.mydomain.com:8080/’ failed: WebSocket opening handshake timed out

Any idea please?


#5

Hi,

I have a similar issue. I come on a free plan from a partner hosting (Dreamhost)
SSL on naked domain working;
SSL on sub1.domain , working, fully hosted at DH
SSL on sub2.domain , not working, CNAME to github.io

Can anyone help?

Alexandre


#6

I don’t know what the partner dashboard looks like for Dreamhost, but do you get :orange: and :grey: options on your DNS entries? Specifically, there are some situations where you can’t :orange: a CNAME entry, so you don’t get Cloudflare coverage, including SSL.

I have a CNAME for an AWS bucket set for :orange: and my Subdomain SSL is working.