Subdomain SSL not working and wordpress admin 404 error

i added ssl for subdomain using this video tutorial

after that i can login wordpress admin but cant able to access dashboard

If Step 2 in that tutorial was "Add SSL for your subdomain in cPanel, you’d be all set. Have you tried that? Cloudflare does offer a free certificate you can install in cPanel.

1 Like

my ssl for subdomain is enable then what is the problem

That looks good. What is your SSL setting here? It should be Full (Strict).

2 Likes

yes it is full(strict) but same problem occurs.

Now that the subdomain is configured for SSL, you may have to manually set the site’s URL in wp-config.php to include HTTPS.

1 Like

in wordpress article there is step #change url directly in database
it says carefully change the URL information to the new address.
but what should be the new address,
eg. http://abc.xyz.com is present
then what should be new address
??

It should be https://sub.example.com, but make sure you have a backup before you make any changes to the database.

now my some pages like home and contact are not secure(ssl disable) but some pages like blog are secure(ssl enable)

and is there changes needed in .htaccess of subdomain?

That sounds like Mixed content. If you add this line to that subdomain’s .htaccess, it should correct that:
Header always set Content-Security-Policy "upgrade-insecure-requests;"

Here’s more info on Mixed Content:

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.