Subdomain ssl error - ERR_SSL_PROTOCOL_ERROR

I am getting the following error in Chrome when trying to access my subdomain wholesale.dabrite.com:

"This site can’t provide a secure connection

wholesale.dabrite.com sent an invalid response.

ERR_SSL_PROTOCOL_ERROR"

However, the root domain dabrite.com loads fine.

I have noticed that if I visit the root domain first and then open another tab for the subdomain it then loads without the SSL error.

I have tried everything including clearing cache, turning off QUIC, reinstalling SSL, moving the site to a different host, etc… I’m stumped.

Have you tried following this guide:

Yes, I have tried everything in that article except for using Cloudflare Origin Certificates. I guess that will be my next attempt at fixing the issue.

Loads just fine for me. Perhaps a local DNS caching error.

A couple of things to check:

Is your hostname proxied in DNS settings?

Visit your DNS settings - do you see Proxied next to the subdomain you are seeing the problem with?

If so, you need to set the hostname to proxied.

  1. Visit your DNS settings and find the DNS record for your website hostname
  2. Click Edit and set the Proxy status to Proxied
  3. Wait 5 minutes and then test again

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.