Subdomain shows "Invalid SSL certificate" error, but SSL is fine

My subdomain shows error code 526 (Invalid SSL certificate). I have tried the following to trouble-shoot this problem:

Contacted my hosting service which did the following:

  • Verified that my SSL is in place and operational
  • Reinstalled my SSL
  • Verified that the site is loading securely
  • Ran a SSL check to confirm the SSL is functioning properly
  • Corrected the URLs to have https from the database
  • Flushed my cache in Site Ground

Then I cleared all cache from Cloudflare

I’m still getting the same error message. Any other suggestions?

1 Like

I was told to “Post the domain and pause Cloudflare” but since my subdomain’s DNS records point to Cloudflare (not my hosting site), pausing Cloudflare just takes my site completely down. The site now says, " This site can’t be reached. The webpage at [subdomain] might be temporarily down or it may have moved permanently to a new web address. ERR_QUIC_PROTOCOL_ERROR

Well, it looks like everything is working! My subdomain propagated and it now showing as a working site, and Cloudflare is turned back on with no SSL certificate error messages!