Subdomain set up going in circles

I’ve done the diagnostic and done everything I can and still get circles…where to start or find help?

I need to work. The CName record looks right, I have SSL set up…I have no idea where to look!

Where? At the origin? I suggest that for starters, you toggle the “portal” subdomain to :grey: DNS Only (and wait five minutes for propagation), then make sure it works with HTTPS.

Where? I’m sorry…toggle it where?

You have to click on that DNS record to Edit it.

Did that - thank you. So now get this error: sent an invalid response.


That would certainly explain the SSL error. Your server doesn’t having functioning SSL for that subdomain.

Okay, I’ll ask them… Thank you. It’s I hope a start to the fix!

1 Like

The SSL is working fine according to’s help desk. All of the possible things there checked out, excluding all this:

exclude the following common causes at your origin web server:

  • No valid SSL certificate installed
  • Port 443 (or other custom secure port) is not open
  • No SNI support
  • The cipher suites accepted by Cloudflare does not match the cipher suites supported by the origin web server

They noted that I should add an A record to THEIR servers, but the site is now being hosted at not POWWEB (the original host).

You’ve set it to :orange: again. Please switch it back to :grey: and leave it that way until you get functioning SSL on that subdomain.

Okay. Done.

Nothing different yet.

That’s to be expected. Your host still hasn’t fixed it. I’m afraid this isn’t a Cloudflare issue, as the connection is going directly to your server.

I’m not sure what you mean by “your host hasn’t fixed it” - given they said “it isn’t them” what is the thing being addressed?

I’m still so confused…

They’re wrong. Or you’re asking the wrong host. Whoever owns the IP address in this connection (the one your DNS records points to…ProductDyno?) has broken SSL. Hint: It’s NOT Cloudflare. It’s a Caddy server hosted at AWS.

Oh wow, yes that makes sense: this is what cloudflare looks like and I don’t know what the… is from any of them.

The productdyno pointer looks to be working. Groove is the one that requires the main domain to be sent through cloudflare for SSL … I think that’s how it is set up

Your ‘portal’ record points to productdyno. That’s the 54. address that’s not working.

Oh wow. I’m stunned by that. Thank you - it’s a start to see if I can figure it out. They offer NO help to set it up… or fix it. There is a link from a few years ago here … CNAME for root domain not available


Product Dyno? Don’t they have instructions on how to get it to work with your domain?

It’s not an issue of a DNS record. Yours should be easier since it’s not the root domain. You already have the DNS record. It’s just a matter of Product Dyno provisioning SSL for your subdomain.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.