Subdomain redirect issue?

Dear Team,

i was hosted one domain on my personal machine with static ip!

and i was using xampp for it.

my domain is hacksleak.in
and subdomain is decrypt.hacksleak.in

and domain and subdomain hosted on same server!

but when i tried to open subdomain decrypt.hacksleak.in then main hacksleak.in only open.
and for hacksleak.in url hacksleak.in was opening !

but have decrypt directory separately but still not redirected to subdomain!

i tried many solutions but no one helped me!

please provide the solution or guide me how to do it!

And below lines added in xampp httpd-vhosts.conf file.

image

anybody having solution for this??

Greetings,

Thank you for asking.

Hm, either this question is more suitable for StackExchange or some similar forum, I’ll try to provide the solution.

Consider moving content of the hacksleak.in which is in your DocumentRoot /htdocs/ to /htdocs/hacksleak/ and apply the change in the httpd-vhosts.conf file too.

Open your httpd.conf file and look for

#NameVirtualHost *:80

Uncomment it.

Change the value for ErrorLog and CustomLog based on your requirement (why are you using the same log for both domains?)

Restart apache2 service.

I do not know which Apache are you using.

And you are using HTTP 80 port, while I can access your websites over HTTPS → May I ask if you are using the Flexible SSL option under the SSL/TLS tab of Cloudflare dashboard for your domain name? :thinking:

in SSL/TLS

i didn’t using any ssl certificate for my domain only Cloudflare ssl is using!
and port opened in server machine 80 and 443;

but in httpd-vhosts.conf file i didnt write any VIrtual Host rule for 443.

Dear Team,

Done setting as per solution but now below error while opening decrypt.hacksleak.in

but we have index file in this directory and write permission also.

image

image

image

Kindly, I’d suggest you to check your .htaccess file for your sub-domain decrypt and also php.ini just in case.
→ you are also running old PHP version …

That 403 error is coming from your origin host/server.

Nevertheless, check access and error log files for any clue due to troubleshooting.

CHMOD set to 755? Try 775 for testing purpose.

If so, but how about user/group ownership of htdocs and sub-directories including the .html/.php files inside? :thinking:

Sir.

its windows server and write permission for all the folders!

Per default, not quite exactly due to Group Policies and other stuff (you are running XAMPP instead of the IIS due to the lack of support for PHP/MySQL).

Unfortunately, it’s an off-topic for this forums either, but I am trying to help to give you any suggestions what and where to troubleshoot something and also which is not anymore related to Cloudflare.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.