Subdomain over HTTPS goes to someone else's site!

subdomain

#1

I have a subdomain set up which points to a different IP than my main site.
I have Full SSL active in Cloudflare with ‘Always use HTTPS’ enabled.
When I attempt to visit the subdomain it resolves to someone else’s site.
When I turn off ‘Always use HTTPS’ it correctly resolves to my subdomain site.

Before moving to Cloudflare managed DNS this was working fine.

How is this possible and how might I fix it?
Is it at Cloudflare’s end or my web host’s?


#2

Probably your web host. Does that web host have an SSL certificate set for your subdomain? I bet it doesn’t.


#3

Thanks for your reply sdayman. I wouldn’t think there is SSL there. But why would there need to be if I’m running through Cloudflare fro SSL?


#4

Because you have SSL set to Full here. That means your server also has to be running SSL.

You can create a Page Rule to fix this:
Match: sub.example.com/*
Setting: SSL Mode (Flexible)

EDIT (so @sandro doesn’t have an aneurysm): It would be nice if that other host could issue an SSL certificate for your subdomain so you can keep using Full SSL for full end-to-end encryption.


#5

Excellent. That did the trick. Thank you so much!


#6

I dont know why you are doing this to me :laughing:

And no, a fineprint (thank God, Discourse does not allow tampering with font sizes) disclaimer does not count as indemnification. :wink:

Point proven, the OP eagerly switched to Fl, Fle - nah, cant pronounce it - and will happily stay there for all eternity until the day the entire world runs on IPv6. :cold_sweat:


In all seriousness though, @adamW, that trick did solve the issue but your site is not secure anymore as data is now transferred in plain text.


#7

Just so you know I do agree it’s best to do it right: Full SSL.

If hosts would proactively add SSL to hosted sites, it would be a better world. Customers should be more demanding of their hosts for Free SSL…or move on to someone who does offer it.


closed #8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.