Subdomain Not Picking Assigned External A Record IP

Hi Guys,

My subdomain is not picking the external IP i have assigned it.
Confirm with screenshots below.

I would want the subdomain dns to pick the IP assigned to it on cloudlfare dns settings.

When I pause Cloudflare and dns management defaults to namecheap, it immedietely propagates correctly.

same as primary domain

anyone with ideas?

This has helped… Thanks.

What can I do about it?
You shouldn’t need to do anything if you want your site to be proxied by Cloudflare, it should continue to function but with Cloudflare’s security and performance benefits. You can set the record to :grey: which will disable these features and the Cloudflare proxy and will then show the IP address you configured.

I’d also suggest you check your encryption mode, as you current appear to have an insecure selection.

It is set to Full.

Precisely, that’s insecure.

So I should do Full (Strict)?

The article has all on that.

Yes - Full trusts any self-signed certificate which any bad actor could get.

Full (Strict) requires a origin CA certificate (from your Cloudflare dashboard) or a trusted certificate that is valid for your domain name.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.