Subdomain not connecting with Tunnel

I have a server set up to connect to Cloudflare via a TLS tunnel. I can connect just fine through the main domain name. (

I tried to set up a subdomain by adding a CNAME record that points “” to “”. It is configured like this:


I can ping and it works, but if I try to access, this request never makes it to my server. It appears to be stopped at the Cloudflare layer.

The host is sitting under my desk with the local network hostname “piguy”. http://piguy and http://highhands.piguy both work as expected. My server listens on port 8080, so I ran sudo tcpdump -i any port 8080 -n to monitor traffic and I see traffic from Cloudflare when accessing the main site, but no traffic when accessing the subdomain. At this point, if we assume Cloudflare is properly forwarding traffic, there might be some setting on the TLS setup I might be missing?

Did you actually setup the subdomain in the Tunnel’s settings in the Zero Trust Dashboard? You need to enable it on the backend…

Here is what I have done:

  • On my server, I edited ~/cloudflared/config.yml to have an ingress/hostname entry for that matches the one for, then I rebooted the machine.
  • On Cloudflare dashboard, under SSL/TLS,Custom Hostnames, I added “” and verified certificate status and hostname status are both Active
  • On the Cloudflare dashboard, I added a CNAME record for “*” with content “

Is this what you meant by “setup the subdomain in the Tunnel’s settings in the Zero Trust Dashboard?”

I hadn’t touched the SSL/TLS part before your message, but even after my changes I still see the same behavior: I can only reach the site, but not I can hit both sites just fine on my local network, accessing the machine directly.

Any more suggestions? It seems like I am missing something really simple here.