Subdomain isnt working after Cloudfare integration

dns
#1

After cloudfare integration subdomain is not working, I tried adding CNAME waited for 24 hrs and A record of it, but none of them worked. please help me to solve this issue

#2

What is the domain and subdomain you are trying to add? Also, can you post a screenshot of the DNS record you added for the subdomain (Redact IPs etc.).

#3

please find,
https://www.zohaweb.com/ is the domain… subdomain - https://www.download.zohaweb.com/

#4

Hi,

As recommended by @domjh, you should redact information like IP addresses in the screenshot of your settings.

Dealing with your issue, your DNS is not being served by CloudFlare:

$ dig +short ns zohaweb.com
ns2.aspirebee.net.
ns1.aspirebee.net.

The first thing to do would be to change the NS records in your registrar.

Once that is done, it should work, as the records seem to be in place:

$ dig +short @james.ns.cloudflare.com download.zohaweb.com
zohaweb.com.
139.99.122.225

Just to note, the hostname you gave (https://www.download.zohaweb.com) is a second level subdomain, and by default the CF SSL certificate will not cover that hostname. (download.zohaweb.com will be fine)

3 Likes
#5

Thank you for your replay,
Please check now, i have changed the Name servers to cloudfare suggested, and its activated. But the issue is with subdomain. it isn’t working,

I created CNAME for SUB Domain, but it shows like:

This site can’t be reached

www.files.zohaweb.com refused to connect.

What else i need to do to activate my Sub Domain too !! its really frustrating tried everything.

Thank you.

#6

As previously mentioned by @michael and elsewhere in the Community forum, you cannot create 3rd level sub-domains.

1 Like