Subdomain is not working in https://

I have made a new subdomain and created a CNAME record with cloudflare cdn enabled. But when you want to enter to the subdomain you have to go trought http:// to enter. But after that it redirects to https:// When you enter subdomain.domain.com (sample) you cant enter to the page and its redirecting to https:// page.

What should I do?
Thanks

Whats the actual hostname? Did you create a respective entry also in your webserver configuration?

new.kubranskinadsenci.tk

No, but it worked in past

Seems to load fine for me on HTTPS -> http://sitemeer.com/#https://new.kubranskinadsenci.tk/

What exactly is the issue?

And yes, unless your configuration is not name based and you dont want to show the same content you will need to create an entry on your webserver as well, along with the proper HTTPS configuration.

Sorry. My bad. Now it works fine, but do you know why is website marked as insecured?

For starters, do you have a certificate on your server as well?

No. But I can see there certificate by cloudflare here (chrome) and its same as kubranskinadsenci.tk - the origin

The certificate you referred to is only Cloudflare edge certificate, you also need one on your server.

OK. thanks