Subdomain is loading a completely different website

I’m encountering an incredibly bizarre issue. There’s two domains in one of my accounts, $merit and $sharp. I encountered an issue yesterday where, when Cloudflare is enabled on $merit, it causes www$merit to return a 404 page. However, it’s a completely different 404 page from my origin server, and based on the fact that my Apache htaccess redirects aren’t being triggered and there’s nothing showing up in my server logs, it’s not being generated from my server.

So I’ve been looking through both sites trying to figure out if there’s any setting that would have caused that, and I remembered that $sharp is supposed to be set up to redirect all requests to both $sharp and www$sharp to a landing page at $merit slash sharpadvisors. I look through $sharp’s DNS records and notice that the www subdomain is CNAMEd to $fmg; and opening that in a new tab shows the same 404 page I was getting when merit was proxied. Additionally, only the root domain was properly being redirected, www$sharp was (and still is) showing that 404 page as well.

Okay, it must be a redirect configuration issue then. I cleared out the Bulk Redirects configuration, assuming it might be an issue with that since it’s in beta, and rebuilt the redirects in Page Rules. Same behavior. I delete the Page Rules and let it resolve straight to the existing IPs. Same behavior. I deleted all of the DNS records for the root domain and the www subdomain and, following the instructions normally used for Worker deployment, I added AAAA records pointing to an unrouted IPv6 address as a replacement (at this point $fmg is no longer referenced anywhere in my DNS). Same behavior.

The only configuration which doesn’t show that 404 page is when there’s no orange-clouded DNS records pointing to www$sharp. Having anything set to proxy on the www subdomain causes that 404 page to be served instead. I have no idea why this is happening, and even less idea as to why the issue would be affecting www$merit as well, which has never had any references to $fmg associated with it. I’ve checked Bulk Redirects, I’ve checked Page Rules and Transform Rules, and I’ve even checked Apps (there’s no Apps enabled on either domain). There’s nothing that would cause this to occur.

The only clue I can find is that if you pull the DNS for $fmg, it’s set up to CNAME to a Cloudflare CNAME, which indicates that domain seems to be running on Cloudflare as well in a CNAME configuration. I have no idea how that would affect my two domains, but it seems like it might be pertinent information.

What could possibly be causing this issue to occur? And why is it affecting both of the domains on that account?

I’m apparently severely limited in the number of URLs I can include in a post, no matter what I try and do. The above post is referring to and, and “fmg” refers to

I can see the issue and that you have the domain pointing direct to the server so it works for now. Have you recently moved hosts for that site?

I suspect this issue is due to an old provider useing Cloudflare for SaaS. Please contact your old provider and ask them to remove any Cloudflare configurations for your domain, specifically SSL for SaaS / Custom Hostnames.

I’ve contacted FMG Suite, who is the previous website provider and the one who’s 404 page is being loaded when Cloudflare is enabled on the site, and they are not able to find any sort of configuration on their end that would cause this to happen.

Is there any other way that I can “regain control” of the site, or otherwise reset its configuration on Cloudflare’s backend? And is there anything else that could cause this issue to occur?

Double check your DNS configuration, what IP’s are specified, and you can turn off the :orange:

You can press the button to Pause Cloudflare, wait awhile and then resume Cloudflare. Doing so should “reset” numerous Cloudflare configurations and is known to fix certain issues with Cloudflare configuration issues where whats displayed in the config isn’t whats actually being set.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.