Subdomain is giving an error uses an unsupported protocol

I just recently tried setting up my subdomain on Cloudflare with the help of my hosting company. However, I’m getting this error: ERR_SSL_VERSION_OR_CIPHER_MISMATCH

I’m not sure what the next step is and any help will be greatly appreciated.

It’s probably this:

1 Like

Thank you @sdayman for your help. I get rid of the SSL error by eliminating a www in front of the subdomain, but now I’m getting “This site cannot be reached” DNS_PROBE_FINISHED_NXDOMAIN

I’m not sure what the next step would be.

What’s the subdomain host name (URL) you’re trying to connect to?

I am trying to connect to blog.myfunctionalcoach.com.

My subdomain is through Dreamhost.

Which is redirecting me to www sub-domain - https://www.blog.myfunctionalcoach.com/ subdomain too deep issue here as @sdayman pointed out:

Thank you. Do you think my only option is to to get the advanced certificate for $10/month? I worked with my main domain host plus my subdomain hosting service. Nobody has been able to figure this out. I was hoping there was something simple I could do to get my blog showing.

You have three choices:

  1. Get ACM for $10/month to cover www under your subdomain.
  2. Not use ‘www’ for that subdomain.
  3. :grey: DNS Only (bypass Cloudflare) for that subdomain.

Thank you so much for your help. I got ACM and ordered the SSL certificate. It’s working now. :grinning:

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.