Subdomain going to https for non-https site

Hi, I have just set up Cloudflare and have gotten it working for the main site.
The main site is fine, and it none of my pages use https as of yet. however, I have a cpanel subdomain and that gets redirected to https instead of HTTP. The cpanel site is HTTP only, there is another link for https site. I keep getting a secure connection failed in firefox because it is trying to go to https. I tried to manually put in HTTP but it keeps getting redirected to https.

Edit: I have turned off SSL setting in Crypto Tab

Is the redirect to HTTPS definitely not coming from your server? Also, check your page rules in Cloudflare for anything that could cause this.

1 Like

I am almost certain that it is not the web server. Before I switched to cloudflare it was working fine. It is only after switching to cloudflare this problem started. However it only does this on subdomain, not the root domain itself. Also, how do I check if the web server is redirecting to https?

If you set that subdomain to :grey:, instead of :orange: on that subdomain, does the redirect still happen?

1 Like

I changed it to DNS only and it worked, thank you

That means you are no longer using Cloudflare’s services on the subdomain, if it works OK like that then the redirect probably was coming from Cloudflare, you should probably check your crypto tab and page rules in Cloudflare to see what could cause that is you want to re-enable :orange:.

1 Like

In the crypto tab everything is the default, what should I be checking? Also, do you have any suggestions for page rules?

Check the Always use HTTPS setting is off under crypto.

For page rules, do you have any configured at all? Of you do, are there any affecting that subdomain that may cause a redirect to HTTPS?

I can confirm that always use HTTPS is off. I also do not have any page rules set up

Maybe @cloonan can take a look to see if he can spot anything… :slightly_smiling_face:

Alternatively, someone else may have an idea, but I have run out, I am afraid!

1 Like

Ok, thanks for your help

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.