Subdomain gives "server not found" (& SSL not working on www....)

My main domain works fine. However, when I try to go to the subdomain, I get the error that the “server is not found”.
The Cloudflare DNS records shows the subdomain with an A record (pointing to the same IP as the main domain). The cloud was grey so I turned it to orange, but it made no difference.

You need to post which host you are talking about and best would be if you can post a screenshot of the DNS record in question. Redact IP addresses if necessary.

I created a test subdomain and added it with an A record. It is here:

It also gives the “server not found” error.
Here is a screenshot of the DNS records:

That record works

It only returns a directory listing, but thats up to the server. The site itself works.

That subdomain appears to work OK for me… Takes me to the index directory…

What is sitemeer? When I try to use the link I get an error:

I don’t understand why the link works for you. Here is what I get:

It seems that the reason that doesn’t work for me is that my browser converts it to

  1. Why doesn’t www.test.smittendolls work? How can I get it to also work?
  2. How can I prevent the addition of the www. prefix?

Somehow, I was able to avoid the www addition on and I then got the test subdomain to work.

However, I am still not able to remove the www from my “real” (private) subdomain, and I assume that is the reason why I can’t connect to it. Any suggestion on how to fix this?

Sitemeer is just a service to do a quick test of your website.

Maybe your browser history has the www version and automatically puts that in your address field.

Have you tried a different browser?

Yes I have tried different browsers and even different computers. The www is always added to the “real” subdomain; If it is “abc”, I get
In any case, why doesn’t work as well as
I didn’t have this issue until I switched to Cloudflare.

BTW, I have an entry in the DNS records:
CNAME www is an alias of

p.s. I just password protected the “real” subdomain (let’s again call it abc), In this case, worked fine (www was not added) and I got the password dialogue. However, after entering the password, it again switched to and I got the “server not found” error again.

That is the reason! www wouldnt work for me either.

That is a local issue and you would need to check your browser configuration as to why it does it. It is not an issue of your site though, loads just fine.

  1. Why doesn’t work as well as It used to work fine w/o Cloudmark.
    Note that the main domain works with or without the www (i.e. both and works)

  2. As I explained, I am able to get to,

  3. However, the main problem is that I am not able to get to my “real” subdomain. no matter what I do. If it is called abc, then is always translated to and I get the error. I have tried with 4 different browsers, 2 different PCs and I also tried it on an Android phone with the same problem.

EDIT: My subdomain contains a wordpress installation (and so does
I just discovered that if I delete the index.php file, then www. is not added and I am able to go to w/o errror! However, I need the index.php file for wordpress to work…
Again, I do not understand why I only have this issue with Cloudflare?

Maybe wordpress is adding the www. If so, then we are back to question #1 above, Why does not work with Cloudflare?

WordPress could be adding the www, in settings - general on the WP dashboard, you can check the site URL. Also check any plugins. takes me to an index page but is working. gives me an error. Have you got a cname record in Cloudflare for pointing to

Well, I can’t go to the WP dashboard since the site is blocked…

No, I didn’t. I didn’t realize that I needed to manually add this!? I added it for abc and test and now both www.test.smittendolls and works! THANK YOU :bowing_man:!!!

How on earth is a beginner supposed to know that this is needed to be manually added for Cloudflare to work for subdomains? In particular, since I had no issues with the www before using Cloudflare…

I have a followup question though:

SSL works for
but not for
Can it be fixed?

1 Like

What is your SSL mode set to in your Cloudflare dashboard? E.g. Flexible or Full?

No problem. Glad I could help!

Forgot to say… You will need to redirect to

Cloudflare certificates cover not www.test. is too deep a subdomain for the free plan.

Either redirect it consider a higher CF plan that supports that.

I am not sure I understand this. Per above, I had already redirected. That is how I was able to access This is what I have:

Should it be done some other way?
SSL mode is set to Full (default). I read somewhere that it is “better” to use Flexible?

Sorry, I forgot about the too deep a subdomain thing. The below should answer your questions.

Adding a Page rule : => worked; SSL works :grinning:
However, => didn’t :slightly_frowning_face:
(it goes to with SSL error)
It is probably because WordPress is somehow redirecting to www (I haven’t figured this out yet) so it goes into a “loop”…

I guess that I don’t need SSL for because it is not a “public” URL (I password protected it to make sure)?

1 Like

This topic was automatically closed after 31 days. New replies are no longer allowed.