Subdomain getting an Error 1000

Hello, Still new here. I have a subdomain off my main site that’s hosted by a third party where I park a ton of photos. The name for that is photos.marcicurtis.com/clients.html. It’s getting an Error 1000.
The third party host (Zenfolio) is changing servers. I followed their directions to change the CNAME record and verified it was working. Now it’s not.

When I test it, it says, " Error: photos.marcicurtis.com does not resolve correctly

We could not find any A or CNAME records for photos.marcicurtis.com. It is recommended that you configure photos.marcicurtis.com with a CNAME record pointing to custom.zenfoliosite.com ."

But I did change the CNAME record. I looked at the Error 1000 tutorial, but all it mentions is “A” records and “AAAA” records. When I try to edit or add any records ( I thought maybe I did the CNAME record wrong by just putting in photos and then they’re address?) or adding in A and AAAA records (which was in a tutorial of Zenfolios for changing from non subdomain websites). It won’t let me. It keeps giving me a red bar with an “Error 1000” at the bottom and won’t let me save anything.

Am I supposed to be putting in the IP address in a new “A” record? If so, which one? I use Transmit for files, so that IP address? I’m hopelessly confuses and very much a newbie.

Thank you for any help. Really struggling here with the lingo and the implementation.

There is a DNS record for ‘photos’, but I bet that because zenfoliosite uses Cloudflare, your CNAME for ‘photos’ needs to be :grey: DNS Only. You can edit it by clicking on that DNS record, then click on the :orange: to toggle it to :grey:, then Save.

1 Like

Thanks for your help!
I am still waiting to see if that worked (it’s been over an hour with the same error message). I don’t think Zenfolio uses Cloudflare, just me. I can get into their backend of their site to upload photos, but my clients can’t get into the front door with the photos.marcicurtis.com/clients.html.

I believe the issue came when I was advised to get rid of one of my “A” records (the one with an * for subdomains). When I did, it messed up my blog and apparently this subdomain as well. I added it right back in and it brought the blog back, but I didn’t check the photos.marcicurtis.com/clients.html link. Maybe I didn’t do it right?
If I need to add an “A” record for zenfolio, where do I find the number to put in the “content” section?
Here’s what my DNS panel looks like now:

Here’s what Cloudflare’s auto response to my question was:
" * The IP that you are pointing to in your Cloudflare DNS is a Cloudflare IP. This isn’t allowed as you need to point to your origin web server. IS THIS THE IP ADDRESS I USE FOR TRANSMIT?

  • There is a reverse-proxy on your origin that is “looping” or using the nginx proxy_pass function to pass the request back through Cloudflare. This isn’t allowed and you will need to use either a redirect to point to another web resources or remove the reverse-proxy." NO IDEA WHAT USING THE NGINX 'PROXY_PASS" FUNCTION IS. I’M A NEWBIE AND THIS MEANS NOTHING BUT DOOM TO ME :slight_smile:

I see that your ‘photos’ CNAME is pointing to that ‘custom’ subdomain, and is not proxied. So that’s good on your part. At this point, you’ll need to ask Zenfolio why it’s not working.

p.s. Yes, they are using Cloudflare. That ‘custom’ hostname returns Cloudflare headers.

Thank you… I will try reaching out to them. You are the only human I’ve been able to reach, so THANK YOU!!! I might be back to ask for a follow up. I appreciate your help and guidance.

1 Like

Thank you sdayman. They were able to do magic at their end and now it works. I APPRECIATE YOUR HELP!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.