Subdomain error over https: ERR_CERT_COMMON_NAME_INVALID

I’m not that tech savvy, especially when it comes to Cloudflare, so would really appreciate any tips from the community. I’ve raised a ticket, but since I’m on the free account it looks like I got an automated response with links to support articles - none of which seem to shed any light over what I might be doing wrong.

So here’s where I’m at.
I set up Cloudflare for, which now works over https fine.
BUT, more importantly, I really want SSL to work over the subdomain I’ve added an A record for this subdomain, set it to proxied, and it works fine over http, but over https I’m getting ERR_CERT_COMMON_NAME_INVALID.

After reading a few other topics, I’ve also tried:

  • Setting www to DNS only (didn’t do the trick)
  • Turning crypto off and on again (to reset it)…again, no change.
  • Set SSL to Full, which didn’t fix the problem either - so it’s back on flexible for now.

Can anyone give any tips to where I might be going wrong?

Is there a way I can change the certificate to “booking” rather than the “*” wildcard?

Thanks in advance


I am able to load your site just fine with https.

You would want the wildcard rather than the just for booking.

Well that’s a facepalm moment then.

Just tried on my phone over 4g…loads fine. Must be cached with the error on our network.

Sorry to waste your time!

This topic was automatically closed after 31 days. New replies are no longer allowed.