Subdomain doesn't works

I’m having trouble with the subdomain. It doesn’t work and doesn’t have SSL protection.
I created the subdomain on my hosting, but being that I have Cloudflare’s DNS, I should put the subdomain’s DNS from you and add to site protection.

What do you mean by it doesn’t work?

If it’s an error about SSL, have you made sure that your subdomain works over HTTPS when the DNS record is not proxied first?

1 Like

Hi @user15657 ,

As said by @KianNH What do you mean by it doesn’t work

Let’s assume you have a domain - testing.com for that you need a subdomain such as help.testing.com

Things to do

Go to your Cloudflare account, click on the domain in which you need to create this subdomain.

  • Along the top menu click on DNS

No alt text provided for this image

  • Under DNS records click on add record

  • Select CNAME from the options

  • Enter the subdomain as the name for instance add xyz (you must put your subdomain name here) In the target add your registered domain name example testing.com

  • Click save.

Also you can use the A record Similar to the CNAME Record only

Type Name IPv4 address Proxy status
A www 192.0.2.1 Proxied

Here’s some info on it you can refer
:arrow_right: https://developers.cloudflare.com/dns/manage-dns-records/how-to/create-subdomain/
:arrow_right: Adding subdomain to CloudFlare

Any Further Issues you can revert back here !!

Sorry, I was in a hurry. I’ll explain better; I have been receiving DMARC errors from Google for 9 days. I have read a guide How to Fix WordPress Not Sending Email Issue to solve this problem. Always, if I understood what the guide said. Do you have a better method without using a subdomain and repairing the DMARC?

Do you need the XML file I received by email?

I’m not sure how that is releated to Cloudflare

Before adding the hints, I notice an error in DNS.

Kindly, correct it by :

MX record for domain oldfreegame.com with the value mail.oldfreegame.com.

Double-check if you have A mail pointed to your hosting/server IP address and is unproxied and set to :grey: (DNS-only).

Great, then I didn’t have to add a subdomain.

I save?

Check if you have or not an DNS record A mail, if not, make sure to add it.

Just in a reverse order, for name make sure it’s oldfreegame.com and the content is mail.oldfreegame.com.

I’ve still the error.

Thanks for feedback and sharing screenshot.

Okay, from the above screenshot I can see there is an existing CNAME mail.

To fix this. make sure to:

  1. Remove CNAME mail by clicking onto the “Edit” and then “Delete” button.
  2. Click on the blue “Add new record” button. Select A for type, then for name type mail, for “content value” type the IP address and make sure “Proxy status” is set to :grey: (DNS-only).

Helpful articles:

May I suggest checking below article if your e-mail records (usually the A mail and the MX record) are configured properly while you are using Cloudflare for your domain name:

I not have understood well.

The subdomain created for emails does not exist. it’s normal? is an address valid only for receiving emails? If so, that’s what interests me.

Please, no guides. I am a beginner and it also confuses me to understand A and B. :frowning:

I still don’t receive the emails. There is no mail.oldfreegame.com. Are we sure I shouldn’t have put the @ symbol?

@ is a replacement for oldfreegame.com, you can type @ or oldfreegame.com, the end result is the same.

What am I missing to have the contact page fully active on my website? I still don’t receive the emails.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.