Subdomain CNAME Error Message

I’m trying to connect a subdomain ( to my Thinkific course (, but no matter what I do I keep getting the error message “Host does not have valid CNAME record” when I try to add my custom domain to Thinkific.

Here’s a screenshot of my Cloudflare setup as of right now:

While I have experience adding custom domains to various hosts, I don’t have experience with subdomains so I’m probably doing something wrong. Any advice would be greatly appreciated!

(Also, my apologies if the answer to this is posted on the Cloudflare Help Centre or elsewhere on the Community–I looked but couldn’t find the answer I was looking for!)

Have you verified that the target, which you’ve obfuscated, exists?

I’m sorry, I don’t understand the question!

I have not used Thinkific, it it sounds like you have not configured a custom domain on their side. Requests coming through Cloudflare use the as the Host header which thinkific is not aware of.

1 Like

Sorry, I should have been more specific: the error message “Host does not have valid CNAME record” is Thinkific’s error message when I try to connect “” as a custom URL.

Right. So it sounds like Thinkific is not configured to respond to your subdomain name.

I had emailed Thinkific about this earlier and this what they said:

"With the way Thinkific sites are set up, we’re not able to place this on a subfolder (eg. on your domain. You would need to create a subdomain to host your Thinkific site. For example, a subdomain comes before your root domain and could be like learn , courses or academy (eg.

In order to set up your custom domain, you will need to create a CNAME record. A CNAME record is what tells browsers where to find your site when visitors navigate to your URL. For more information and steps on how to complete this > Custom Domains."

I checked my subdomain CNAME record for on MXToolBox like Thinkific suggests and it says, “DNS Record not found.” I also checked my main domain CNAME record and I got the same thing even though it’s working.

So lost.

Try editing that CNAME record and click on the :orange: icon to switch it to :grey: (DNS Only). Some hosts don’t recognize it when Cloudflare proxies a CNAME record, which makes it look like an “A” record with IP addresses.

1 Like

Just tried that and got the following error: “Authentication error (Code: 10000)”

I think that’s all we can suggest without knowing the actual hostnames. You can open a Support Ticket.

To contact Cloudflare Customer Support, login & go to and select get more help. If you receive an automatic response that does not help you, please reply and indicate you need more help.

Oh, your last suggestion worked! I just needed to logout and log back in. Yay! Thank you so much!

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.