Subdomain A Record Pointing to Root Domain

I have two A records, one for my root domain example[dot]com, another is for blog[dot]example[dot]com. However the blog subdomain doesn’t work, and using traceroute and sites like mxtoolbox I found it lead to example[dot].com’s IP.
If I switch from proxied to DNS-only, it pointed to the right IP, and switching it back to proxied returned it to example[dot]com’s IP.

I also tried installing origin certificate as instructed in https://support.cloudflare.com/hc/en-us/articles/115000479507

Did I make some mistake somewhere?

I’ve seen some threads in this forum with similar problem, but most of them ended without successful answer.

So it’s not working? What’s the full hostname of that subdomain?

Cloudflare is a reverse proxy. The IP address of a site when :orange: will not correspond to the IP address of the origin. That’s fine/expected?

What error, specifically are you receiving?

Cloudflare is a reverse proxy. The IP address of a site when :orange: will not correspond to the IP address of the origin. That’s fine/expected?

Right, I just realized it’s not pointing to root domain as well, but always to cloudflare’s IP. I have two A record, one pointing to a sample placeholder site on Azure and another to webmail (zoho), so I thought it will just work when I added the third one. I guess I still haven’t fully grasped how Clodflare works.

So it’s not working? What’s the full hostname of that subdomain?

It’s blog[dot]fathuzzaman[dot]id. Accessing directly via IP address works, but I get Host Error via cloudflare proxied

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.