Sub domains not working all time

Hi,

I have already added subdomain entry under DNS. but subdomains are not working properly for all time. like if I refresh my subdomain site or call any file more 3-5 times it redirect to main domain and says subdomain not exist, I need to click back to reach to subsite again.

What could be the issue? How to fix it? Thanks

Greetings,

Thank you for asking.

Before moving to Cloudflare, were your sub-domains working over HTTPS connection? :thinking:

May I ask if they are like example sub.domain.com or www.sub.domain.com? :thinking:

May I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?

Not sure if it’s HTTP(S) issue, if so:

May I ask have you tried using a different Web browser, or tried clearing your Web browser cache?
How about using a Private window (Incognito mode) or a VPN connection if possible?
Is it the same behaviour on your mobile phone (4G LTE, mobile data, cellular)?

And it’s pointed to the correct IP address, therefore status is proxied :orange:? :thinking:

Hi @fritex

Thanks for your response. Here is detail about your queries:

  1. Sub domains are working over https without www, you can check this sub domain: https://healthwebsite.coachleads.pro/ if refresh multiple time it move to main domain.

  2. SSL option selected “Full” under SSL/TLS tab

3.Yes, DNS entery is already added for subdomain and its status is proxied. And it is pointing to correct IP, that’s why subsite works, but with too many reloads or ajax requests from subdomain. It redirect to main domain.

  1. Yes, tried in multiple browsers Mozila private mode, Google chrome guest mode, Microsoft edge guest mode.

If we normally access subsite it works, but if we post some ajaxrequests or reload several times it redirect to main domain. Please help me with this.Thanks

Hi @fritex

Could you please help on this? Thanks

Thank you for feedback information.

I cannot replicate this at my end.
I refreshed enough times in different Web browsers and cannot get the same result as you.
It doesn’t redirect me, nor loads “main page”. It stays “as-is” on the sub-domain URL.

I am not aware of the code itself, neither what the response does look like, nor should be a JSON format or rather HTML code, or something else :thinking:

Furthermore, the Ajax form for “newsletter” is working fine.

I can see you’re using WordPress too.

Hi @fritex

Thanks for your response. Yes, you are correct, we are using WordPress.

Please use this URL and try with updating query string and refreshing several time. You should be redirected to main domain,

https://healthwebsite.coachleads.pro/work-with-me/?sdfkjhsdjkfhkjsdf=098sd09f80d

Thanks

Nope, still I cannot replicate it.
HTTP 200 always. There is no redirect, nor 301/302 HTTP status.

Hi @fritex

It not happen all the time, it happen when access any URL multiple times. You can check attached gif, It is redirecting from subdomain work with me page to main domain registration page. Thanks
Subdomainfail.gif

Hi @fritex

Could you please help on this? Thanks

I am sorry, but I really cannot reproduce this on my device.

It’s working fine at my end, it doesn’t try to load wp-signup as you’re experiencing it.

However, I see a 302 Redirect in your network tab.
I’d say it’s WordPress related or some WordPress plugin and not the Cloudflare.

Kindly, I’d suggest you to write a ticket to Cloudflare support due to your account and/or domain issue and share the ticket number here with us so we could escalate this issue:

  • Login to Cloudflare and then contact Cloudflare Support by clicking on the Get More Help button. If you get automatic reply, reply and indicate to it you need more help and reference to this topic
  • Or send an an e-mail to support[at]cloudflare[dot]com from your e-mail associated with your Cloudflare account

To enable efficient troubleshooting by support, please ensure you include the following on the ticket:

  • example URL(s) where you are seeing the error
  • screenshot / video you provided here
  • Also include two HAR file(s) : one detailing your request with Cloudflare enabled on your website and the other with Cloudflare temporarily disabled - see How do I temporarily deactivate Cloudflare

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.