Sub-domain seems to be redirecting to root domain


#1

I use cloudflare to manage dns for my domain, and host a static site in a google bucket https://nwat.io. This has worked well for some time. I want to add a new sub-domain wip.nwat.io that points to a different bucket. According to Google, all I need to do is create a bucket with the name of the sub-domain, add the appropriate CNAME redirects.

I set this up in CF, and the sub-domain is loading, but it is loading the content from the root domain. I’m trying to work through this and figure out if is a configuration error, or a different issue. This is the DNS setup:

Thanks!

[]$ dig nwat.io

; <<>> DiG 9.11.1-P3-RedHat-9.11.1-2.P3.fc26 <<>> nwat.io
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 57619
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;nwat.io.			IN	A

;; ANSWER SECTION:
nwat.io.		279	IN	A	104.24.100.60
nwat.io.		279	IN	A	104.24.101.60

;; Query time: 7 msec
;; SERVER: 199.21.87.140#53(199.21.87.140)
;; WHEN: Fri Nov 03 22:42:16 PDT 2017
;; MSG SIZE  rcvd: 68

[]$ dig wip.nwat.io

; <<>> DiG 9.11.1-P3-RedHat-9.11.1-2.P3.fc26 <<>> wip.nwat.io
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 14250
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;wip.nwat.io.			IN	A

;; ANSWER SECTION:
wip.nwat.io.		300	IN	A	104.24.100.60
wip.nwat.io.		300	IN	A	104.24.101.60

;; Query time: 20 msec
;; SERVER: 199.21.87.141#53(199.21.87.141)
;; WHEN: Fri Nov 03 22:42:24 PDT 2017
;; MSG SIZE  rcvd: 72

#2

It doesn’t look like I have enough permission to delete or resolve this issue. I found a partial solution on the google side which was an incorrect content mapping. When CF is enabled, I still see some issues even after purging caches. I will resubmit a new topic if the issue doesn’t resolve itself after a while.