Sub-domain getting ERR_TOO_MANY_REDIRECTS

I am using a sub-domain that redirects to an external bucket to serve images on my website. Everything was working fine until about 14 hours ago. The images are no longer loading. And when I tried to access the sub-domain URL directly, I get ERR_TOO_MANY_REDIRECTS.

I’ve already tried disable page redirect rules, but it is still not working. CNAME is configured correctly.

Everything was working fine until about 14 hours ago. Help, please.

Just a quick note. I’ve done a test using another domain and Namecheap DNS with the same CNAME settings. The sub-domain redirection with the same settings works fine using Namecheap DNS.

Any pointers what could be the issue on Cloudflare?

What’s the affected image URL in question?

By the way, you probably need to follow the troubleshooting steps here: Gathering information for troubleshooting sites · Cloudflare Support docs.

Thanks for your reply.

[URL using Cloudflare](

[URL using Namecheap](

Images are all stored in the same s3 bucket. CNAME settings are the same. Page redirect rules on Cloudflare are disabled.

Everything was working fine about 16 hours ago and suddenly it just stopped.

Is Cloudflare experiencing any issues with any of their services (DNS, etc) at this moment or has some settings on Cloudflare changed?

Kindly check if you are using “Flexible” as your SSL encryption mode, as you should use the “Full (strict)” mode, which usually solves this kind of issue.

Yes, it’s been on “Flexible” all these while.
Everything was working well for many months without any issues.
Page redirect rules are disabled, even though it’s been working for many months too.
I’ve absolutely no idea what’s the issue causing this ERR_TOO_MANY_REDIRECTS now.
I’ve even cleared cloudflare cache, but it’s still the same error.

Try switching the setting to Full (strict) instead. The redirection could be coming from S3, where it attempts to redirect you to HTTPS link when it receives traffic via port 80 (which is the port that the Flexible SSL mode will connect to).

1 Like

Switching to Full and Full (strict) gets me Invalid SSL certificate Error code 526.
I don’t think the redirection is coming from S3. If the redirection is coming from S3, it’ll affect my test URL as well. Which is why I’ve setup a test URL on a different DNS provider with exact same settings, for comparison.

Another quick note. Even if I’m to turn SSL off, I’m still getting ERR_TOO_MANY_REDIRECTS.
I don’t think it’s an issue with S3.

That is a step in the right direction, keep it on Full (strict).
Next, you need to install a valid SSL certificate on your webserver. You can get a free Cloudflare Origin certificate for this:

You have two redirects. With the flexible SSL setting, Cloudflare redirects you to the insecure HTTP protocol.

The application on your server however seems to require HTTPS and thus redirects again.

To fix this, select Full (strict) and install a certificate on your server.

Nothing to do with SSL certificates. All the necessary ones are already installed on the server. S3 bucket is using SSL from bucket provider, hence the Flexible mode.

As mentioned, everything’s working well for many, many months include SSL. Suddenly it just stopped working.

Nothing to do with S3 bucket. Already tested with another domain/DNS provider and ruled it out.

Just saw on Cloudflare System Status

Update - Cloudflare continues to investigate ongoing impact caused by unusual traffic activity that is causing 5xx errors, such as 502s, to be returned to some requests.
Sep 28, 2023 - 07:32 UTC

Just wondering, could this be causing the issue that I’m facing?

No, the problem is that you are using flexible ssl mode and refuse to secure your server.

Why don’t you humor me and install the certificate? Shouldn’t take more than 2 minutes.

As mentioned, the certificates are already installed on my server. The S3 bucket is hosted separately in decentralised web3 storage and does not allow own SSL certs. Only allowed to use their SSL certs. The SSL cert for secure connection to the S3 bucket is already enabled in my DNS settings.

There is a reason for Flexible mode.


It seems that cloudflare is having issues with its DNS servers. I’ve switched to another DNS service and everything is loading fine using the same settings.

Thanks to everyone who had replied.


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.