Stuck on last steps connecting to Wasabi

Hello! I am attempting to set up a static site using Wasabi as the storage and Cloudflare as the CDN.

After following the instructions at: https://wasabi-support.zendesk.com/hc/en-us/articles/360018526192-How-do-I-use-Cloudflare-with-Wasabi- I am stuck.

My bucket is in the us-east-2 region with Wasabi so the region URL is s3.us-east-2.wasabisys.com. The bucket name is set to match the domain I am trying to proxy through CloudFlare.

My question is, should the CNAME content be simply the region domain? Or should it take the form bucket-name . region-domain? Or some other form I am missing?

The name value for the CNAME record is the domain I am trying to connect. At the moment I am only listing the region domain (as seems to be indicated in the article) but that is resolving my domain to the wasabi homepage.

Any help is greatly appreciated!

The CNAME would have to include your domain/bucket name. That way Wasabi knows what content to deliver for the CNAME.

Thanks! Now comes the clarifying questions :slight_smile: The Wasabi documentation states that the bucket name has to match the domain we are trying to connect through a CNAME record. So I’m assuming that the CNAME target needs to be my-domain.com.s3.us-east-2.wasabisys.com

When I did that previously, I ended up at the Wasabi homepage.

I’ve gotten this working with an Amazon S3 bucket and, in theory, Wasabi interacts the same way. So I feel like the documentation is not quite what it needs to be.

I agree that it sounds like an Amazon S3 bucket setup. So the bucket name should match the hostname, which might even be a subdomain. When you’ve tried this, were you setting the DNS entry to :orange:? I’d start with :grey: just for baby steps.

I’ll definitely give that a shot. Since I have it working on S3 proper, I’ll probably tinker with the Wasabi setup on a domain where I don’t care about the traffic.

Thank you for the help!

1 Like