Stuck in Upgrade Connection Info

Uptill yesterday, everything was running as smoothly as possible. But for all of today I’ve been stuck as it is not connecting and says Updating Connection Info.
I have tried resetting the settings and reinstalling the app too, it doesn’t seem to work.

I am running Android 8.0 on Moto G4 Plus. Help will be really appreciated.!



  1. Have you investigated this problem When connected to a WiFi (broadband) network and When connected to an LTE network?
  2. Is battery saving mode enabled on your phone?

I have tried everything on my end and yes the battery saving mode is off. I also reported this problem through feedback and the conversation is ongoing, I have been relayed the information that it was a known issue occurring only in India but haven’t received a solution yet.

Are you sure your ISP has not blocked Warp?

I too struck in updating connection info

Me too facing the same problem

Can you tell me how to solve this issue

I did try using different LTE connections and also through the broadband. But the issue is still persistent. So, I don’t think that the ISP has blocked it and also it can’t be an issue with my device as it is not working on other devices as well.

Or maybe it has blocked it as it seems to be working fine when I tried it on my neighbour’s broadband. I’d like to add that the DNS without Warp works fine but it does not have the same VPN capabilities. Is there a workaround so that I can get it working? Please let me know.

It’s working for now. It was something on Cloudfare’s end, thankfully it’s been resolved.
Thanks for your help.