Stuck in Checking Your Browser... when visit website

It told me Please allow up to 5 sec. but it just stuck there.
I tried using VPN, using mobile hot-spot, restart my browser or computer. But they did’t work.
Ray ID: 67876618efbf0a82

What website? Could you please expand your problem? What VPN are you using?

This problem occurs whether I use vpn or not…However, this vpn was set up on my vultr’s Tokyo server

But what website are you trying to visit? Probably your IP was marked as suspicious and the website wants to execute the integrity check test.

That’s what I thought. So I tried wired networks, mobile hotspots, using vpn, all inaccessible

Sometimes if it gets stuck at that point, it’s due to a browser plugin. Have you tried a different browser or incognito mode? Different device?

Yes, it can visit in normal by other browser. But in fact, I’m using the login function of an Android app which is based on http. So changing the browser doesn’t do anything substantial.

This is most likely why your browser is not passing the JavaScript Challenge.

1 Like