Strip response cookies enabled

on all my websites I need the “Strip response cookies” to be enabled in the plugin for the caching to work and get the status cf-cache-status: HIT

The problem is on one website is that this then prevents you from being able to add products to the woocommerce basket.

How to get round this issue?

thanks in advance

the Strip response cookies is an option in the wordpress Cloudflare plugin by Optimole.
even with mimify disabled the site behaves the same way.
“strip response cookies” enable speeds up the website considerably because caching is working but it’s no good if you can’t add products to the basket.
are exceptions which have been added to no avail.

You can’t.

Without cookies, your user can’t shop. They’ll never get the secret cookie that identifies them as a specific shopper.

If every page is cached, it will show the same page for every user. How will a shopper be able to see an updated cart at the top of the screen, or view a checkout screen with their items if that page is cached for all to see?

1 Like

Hi Thanks for the reply, I get that, but what I don’t get is why I can’t get caching to work for static elements without having to enable strip response cookies…

Your static elements are cached now, and I’m able to add items to the basket. Is there something you’re trying to achieve that’s not working at this moment?

Well today this is cf-cache-status is saying its DYNAMIC. normally this says BYPASS

The Main thing is the website is running extremely slow according to GTMetrix.

I can disable the Cloudflare Caching plugin completely and delete all the cache and the website performance is the same.

Only when cf-cache-status=HIT does the website performance improve massively.
but for this to be achieved i have to enable strip-response-cookies which breaks for the shopping basket for reasons already explained above.

many thanks for the help


It’s because your server is slow. Cloudflare can not fix that. If you want to run an eCommerce site, you need good hosting.

I know that’s part of the problem, it’s all the client can afford at the moment. but Caching should help to improve this, but in this case it does not help at all.

No, it won’t. There’s no way around it. In an eCommerce site, the page content can not be cached. It has to come from the origin.

All the static elements (images, CSS, JS) can be cached.

Look at the following page load. It takes several seconds for the server to generate the home page HTML dynamically (first arrow). When a static CSS file (second arrow) comes from the server, it takes less than a second. When a CSS file is cached by Cloudflare (third arrow), it’s lightning fast.

Your client needs to take a harder look at their priorities and expectations.

She’s a young student mate, just starting out in business. She’ll get there. I still think the caching is not working as efficiently as it should do…

Thanks for your help. adding the cf-cache-status custom column has definitely helped me to see better whats’ going on with the website. so thanks for that little tip

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.