Streams Upload with a link invalid 10010

[SOLVED] it issue from my load-balacing nginx server config

My link:

It available to stream on browser but can not upload to CF via link
I was try to use ngrox to try it success upload!

Please show me some sugestions to fix this issue!

1 Like

Same thing, followed the curl command given under the “Use API” tab

Here’s the error response:

“result”: null,
“success”: false,
“errors”: [
“code”: 10010,
“message”: “Invalid URL”
“messages”: [
“code”: 10010,
“message”: “Performed a HTTP HEAD request, but HEAD request did not include a content-length header. Please make sure your origin returns content length headers.”

We’re investigating this and will update this thread shortly.

1 Like

screenshot when using the web interface fyi

Hi there, you are receiving this error because the server with the video file is not returning the content-length header.

Stream’s upload-via-link feature requires that the server hosting the original video file return the content-length header.

1 Like

Hi Zaid

So that means it might not work on a lot of video links? Because I don’t have control over what headers those servers would return

1 Like

Hi Zaid,

Is content length must === video size in byte?

Hi Zaid

mp4 videos work now after adding a content-length header, but I tried uploading a .mov video with content-length in the header and still got the invalid url error:

curl -I

HTTP/2 200
content-type: video/quicktime
content-length: 375
date: Mon, 19 Jul 2021 14:30:03 GMT
last-modified: Tue, 18 Aug 2020 02:55:41 GMT
etag: "ac8f6ced55d9f22d0914df8610ef13fe"
accept-ranges: bytes
server: AmazonS3
x-cache: Miss from cloudfront
via: 1.1 (CloudFront)
x-amz-cf-pop: HKG60-C1
x-amz-cf-id: _ticubHOIamp0wBo0V8ZFWm0h4wgMiCBrWaoGd8aXckAFF7m-BTx2w==

Is there anything else I need to be aware of when uploading .mov files?

I have the same problem
Both of codes below looks the same on the website you posted above, except for the user_agent (i tried many user agents without success)

when i type this on terminal it works:

curl -X POST -d '{"url":"","meta":{"name":"cl8pe"}}' -H "X-Auth-Key: KEY" -H "X-Auth-Email: [email protected]"

my php code below doesnt work:

//     $ch = curl_init();

        curl_setopt($ch, CURLOPT_URL, '');
        curl_setopt($ch, CURLOPT_RETURNTRANSFER, 1);
        curl_setopt($ch, CURLOPT_POSTFIELDS, "{\"url\":\"\",\"meta\":{\"name\":\"Clipe\"}}");
        curl_setopt($ch, CURLOPT_POST, 1);

        $headers = array();
        $headers[] = 'X-Auth-Key: KEY';
        $headers[] = 'X-Auth-Email: [email protected]';
        $headers[] = 'Content-Type: application/x-www-form-urlencoded';
        curl_setopt($ch, CURLOPT_HTTPHEADER, $headers);

        $result = curl_exec($ch);
        if (curl_errno($ch)) {
            echo 'Error:' . curl_error($ch);
            return curl_error($ch);
        curl_close ($ch);
        return $result;```