Stream not access from specific ISP

Hi, I’am from Turkey, we are using Cloudflare Stream Service and other dns service, We can access to web site but can’t access to stream videos. Our Internet Service Provider (TURK TELEKOM ) may banned Cloudflare Stream DNS, IP or something ? Or is Cloudflare banned some ISP access ? Because we are not access to videos with this ISP. When we open videos with other ISP, it’s working. How can we fix this problem?

3 Likes

Try and access https://cloudflare.com/cdn-cgi/trace from the affected ISP’s network - that’ll give you an indication as to if it’s an issue reaching Cloudflare’s network or not.

I didn’t understand. Is this valid for stream too ?

fl=336f86
h=cloudflare.com
ip=85.103.15.12
ts=1650009644.932
visit_scheme=https
uag=Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/100.0.4896.75 Safari/537.36
colo=IST
http=http/2
loc=TR
tls=TLSv1.3
sni=plaintext
warp=off
gateway=off


I can’t access videos in Cloudflare panel also.

1 Like

Try https://videodelivery.net/cdn-cgi/trace specifically - although I don’t think that should make a difference.

/cdn-cgi/trace is ‘intercepted’ by Cloudflare and it’s a test to see that you can reach Cloudflare, but not the origin behind that website, if you can load it but the website itself doesn’t load.

https://videodelivery.net/cdn-cgi/trace did’t load from browser. What is this mean ?
Get ERR_CONNECTION_TIMED_OUT error on Chrome.

This was working ISP trace routing
Tracing route to watch.videodelivery.net [104.18.47.221]
over a maximum of 30 hops:

1 2 ms <1 ms 1 ms 192.168.0.1
2 * * * Request timed out.
3 23 ms 9 ms 9 ms 172.25.44.5
4 9 ms 9 ms 12 ms host-195-33-217-221.reverse.superonline.net [195.33.217.221]
5 12 ms 8 ms 12 ms 10.40.169.233
6 9 ms 11 ms 9 ms 10.40.148.2
7 12 ms 9 ms 10 ms 10.40.140.21
8 11 ms 9 ms 12 ms 10.38.211.206
9 9 ms 14 ms 13 ms 10.40.171.211
10 11 ms 10 ms 11 ms 10.36.6.38
11 37 ms 36 ms 37 ms ae6.bucarest1.buc.seabone.net [93.186.132.6]
12 102 ms 88 ms 89 ms cloudflare.bucarest1.buc.seabone.net [93.186.132.11]
13 56 ms 61 ms 57 ms 104.18.47.221

Trace complete.

And this not working ISP
Tracing route to watch.videodelivery.net [213.14.227.50]
over a maximum of 30 hops:

1 3 ms 83 ms 3 ms ADSL [192.168.1.1]
2 5 ms 5 ms 5 ms 212.156.201.96.static.turktelekom.com.tr [212.156.201.96]
3 13 ms 11 ms 7 ms 81.212.107.221.static.turktelekom.com.tr [81.212.107.221]
4 * * * Request timed out.
5 * * * Request timed out.
6 * * * Request timed out.
7 * * * Request timed out.
8 * * * Request timed out.
9 * * * Request timed out.
10 * * * Request timed out.
11 * * * Request timed out.
12 * * * Request timed out.
13 * * * Request timed out.
14 * * * Request timed out.

Hey! We tested from 48 locations with several ISPs and don’t see an issue broadly in Turkey. Please note that the IP 213.14.227.50 is not a Cloudflare IP address so I suggest check if you have some sort of block or parental controls turned on in your router or with Turk Telekom/Superonline.

Hello everyone,

I have got same issue on *.videodelivery.net.
My end users informed me about this issue and i tried to access some subdomains of videodelivery.net (watch, embed, iframe) from several ISP’s (Turk Telekom, Superonline, Kablonet) but i didt access.

I’ve attached trace route result above. Maybe it can be helpful.

Tracing route to watch.videodelivery.net [104.18.47.221]
over a maximum of 30 hops:

1 2 ms 3 ms 3 ms 192.168.1.1
2 6 ms 6 ms 5 ms 46.197.152.1
3 20 ms 19 ms 19 ms 10.59.11.109
4 22 ms 20 ms 22 ms 10.40.171.123
5 * * * Request timed out.
6 * * * Request timed out.
7 * * * Request timed out.
8 21 ms 20 ms 19 ms 10.38.211.242
9 * * * Request timed out.
10 * * * Request timed out.
11 * * * Request timed out.
12 34 ms 31 ms 31 ms cloudflare.bucarest1.buc.seabone.net [93.186.132.11]
13 35 ms 34 ms 36 ms 104.18.47.221

Hi again,

I think i found the problem. I checked videodelivery.net on Turkish Access Providers Association and i saw its blocked with the court order.

Is there a any alternative domain?

Hi, thank you.
At least, i finally know where the problem is. Classic Turkish banned problem.
If you find any solution please let me know, thanks.

Hi Enes,
If you find any solutions (other than going abroad) please write here. We have also a problem and don’t know anything.

Which Browser are you using?

If it’s Chrome, disable QUIC and test again:

In the Chrome address bar type: chrome://flags Scroll down until you see Experimental QUIC protocol and choose Disable.

@SpaceIgniter, thanks for reply. But nothing changed. Even though my clients won’t do this.
@erenilhan1 I think this isn’t resolvable by us. Because there is a court order about banned this url (videodelivery.net). And objection to court order deadline is today. Even if we objection, it will be finalized positively or negatively after at least three months.
Only Cloudflare fix this problem. I think i will be carry videos to another stream service. Because this is not easily solved.
Cloudflare help us :smiley:

I’m agree @enesselek. It is not resolvable by us. There is an alternative domain as i known - watch.cloudflarestream.com, its not banned but its work on videodelivery.net. So we cannot solve problem.

I will wait a few days. If there is a no solution, i will move my contents to another provider.

Hi all,

I think i found an temporary solution.
cloduflarestream.com also working for Stream service. I was using script below for embedding videos.
<stream src='{0}' controls preload ></stream><script data-cfasync='false' defer type='text/javascript' src='https://embed.videodelivery.net/embed/r4xu.fla9.latest.js?video={0}'></script>

  • I downloaded r4xu.fla9.latest.js into my web project and modifed its content. It was using a html file named iframe.fla9.babb871.html for on their domain.
  • I also downloaded that html file into my web project and replaced file paths to my domain name.
  • iframe html file was calling iframe-player.444b0706.js and i also downloaded it and replaced all videodelivery.net to cloudflarestream.com in this file.
  • And changed my embed code like below then worked for me! Video streams coming from cloudflarestream.com and its not banned for now.

<stream src='{0}' controls preload ></stream><script data-cfasync='false' defer type='text/javascript' src='https://{my-custom-domain-bla-bla}/r4xu.fla9.latest.js?video={0}'></script>

Hi,
Thanks for your solution @ismailperim i will try but if this url will banned then what? This is too risky for me. There isn’t guarantee for not banning new urls. I think i will try new stream service in Turkey or have a representative in here, if i can find. At least we’ll have a decent interlocutor.

Same it’s happening in Spain. I can’t even see the Stream video example you have on your docs.

Please, anyone can help with this? It’s critical.

Can you drop me a note with your IP so we can investigate? My email is zaid at Cloudflare.com

Hey zaid,

Mail sent, thanks!