Strange subdomain redirect

redirect
#1

Hi,
I created a subdomain for a staging site. Point this to IP1. I am running two sites on this IP as a plesk server. The staging site URL kept on redirecting to the other site on the server. So i pointed the new subdomain URL to a completely new plesk server. (all of the DNS is on cloudflare). The URL still redirects to the old IP and incorrect website. This happens from multiple computers on different networks. However if I open a private browser the URL resolves correctly, this also works correctly on my mobile phone.
Can anyone advise?

Thanks

0 Likes

#2

Whats the URL?

0 Likes

#3

centralskiphire.digiayemedia.co.uk - this should point to a wordpress holding page

0 Likes

#4

A HTTP request gets redirected to HTTPS (possibly directly by Cloudflare), but the subsequent request does not redirect but throws a 503 error with a coming soon page.

0 Likes

#5

For the life of me I cant see whats changed. I have another 3 staging subdomains on cloudflare all working without issue. I have an https redirect on the server. I would have thought it would throw up an error rather than redirecting to a completely different IP though

0 Likes

#6

It doesnt redirect me to a different, the only redirect I get is HTTP to HTTPS.

Are you sure you are talking to the right server? DNS propagation.

0 Likes

#7

I have resolved this. (after a week of banging my head on the desk). Since you could see it I changed my wired network to a different wireless one - issue recurred. Tried another browser - it worked. It was bloody chrome serving me up a cached version. No wonder i drink. Thanks for the help!

0 Likes

#8

That usually helps :smile:

1 Like

closed #9

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

0 Likes