Strange domain pointing (without www go to english site)

Hello all
Sorry for my newbie question but it seems strange.

www.myDomain.com send to the right place (my french home page)
myDomain.com (without www) point on my english version… Very strange… (I’m in France)

Note : My site is hosted on Siteground which offers cdn via cloudFlare.

Ideas ? track to start ?
Thank you

It sounds like the server isn’t properly configured for the non-www URL. I suggest you add a Page Rule to redirect:
Match: example.com/*
Setting: Forwarding URL (301) to https://www.example.com/$1

You can leave the $1 off if you don’t want to forward the path from the non-url redirect.

Thank you sdayman !

I would like to have a clean install. I prefer avoid using 301 redirection for something which normaly doesn’t need it.
I think myDomain.com should point to www.myDomain.com, not to www.myDomain.com/en/englishHome

I didn’t notice this problem before cloudflare activation from my siteGround hosting plan. CloudFlare needed domains with www and made me change something in dns.

So I think that the problem AND the solution should come from cloudFlare…

Do you think I am wrong ?

You can troubleshoot this by setting the non-www record to :grey: DNS Only. Give it five minutes to take effect, then see if it still points to English version.

ohoh, thank you to help me…
But I have no idea about what you’re talking to me…
Where can I set it ? how ? sorry… :slightly_smiling_face:

You might have to ask Siteground about this. I don’t know what their Cloudflare setup looks like. On Cloudflare accounts, it’s in the DNS Records list.

Yes, my dns “manager” is at Siteground. So you think the way to solve the pb is only by dns records ?
Thank you for your help

I have no idea why your site does not work as expected. Siteground is your best source of information, as they’re your host and control your entire configuration.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.