Stoopid Newbie


#1

HI all,

I’ve tried dig around to find answers to this but I think the questions are so basic that its hard to find an answer! Apologies in advance if I’ve missed something obvious!

1. Server Offline
I’ve enabled the option “Always Online” but if my server is overloaded, the home page and other sub pages that I’ve seen still show an error message saying there’s a problem with the server.
Does ‘Always Online’ not kick in in this instance? I would have thought that would be the whole idea.

2. Pages Not Caching
I’ve created rules to “Cache Everything” on my homepage, my sub pages and everything in the images folder but when I visit the website, the page load time is still really slow. I had assumed from by setting the previous settings that these pages would load straight from the CDN and not involve my webserver, if this not the case? There are no querystrings, etc. or anything that should trigger a reload.

When I use the Chrome DevTools, I can see resources load quickly but the actual homepage document takes around 6 seconds to load (and obviously nothing else loads until that completes), indicating its not being cached.

3. No Compression
I also see that the HTML, CSS and JS are not compressed despite enabling this feature - do I have to explicitly turn apply this using Page Rules as well as enabling the feature?

Again, sorry if these are silly questions.

Bob


#2

Hi @bobmckay, if you want to share the domain name, this community of other Cloudflare users may be able to assist.


#3

Ha ha! I forgot to include it! This doesn’t paint me in a good light does it?

Here (shortened to keep it out of search engines): https://tinyurl.com/cambschol


#4

I’m only getting too many redirects.


#5

Thanks for this - for some reason I am now getting this too. The setting for SSL was set to “Off” so I don’t understand why the redirect started occurring (especially as it wasn’t occurring earlier, despite me confirming the DNS was resolving to CloudFlare).

I’ve changed this to FULL now (as the origin server supports SSL), presumably this is OK?


#6

Everything seems to be working great. Full is good, Full (Strict) is ideal.


#7

Unfortunately now I’ve solved the re-direct, the issues above are still a problem. Page assets definitely load quicker (images, JS resources, etc.) but the actual HTML document is still taking closing to 7 seconds in general, here’s what I see on the Google DevTool Network tab:

And all the HTML (when it loads), CSS and JS is all still uncompressed.


#8

Update: looks like compression is now working! Its just the initial page load thats the problem.

For some reason, CloudFlare doesn’t seem to be caching the actual HTML pages.


#9

Looking at the statistics in CloudFlare, it also appears like the vast majority of content is remaining uncached for some reason (but there’s not details of what is and isn’t being cached):