Still not http to https


#1

Today morning I add SSL certificate through cloudflare. After completing all the necessary steps my website is still not on https. Please checked that what’s going on. My website is sharingwithworld.com I also add some screenshots please checked that…


#2

It looks good from here. Did you try clearing your cache?


#3

@user628 can you send me the screenshot for this. Because on my side it’s still on http… Yes I cleared the cache…

Thanks for your reply…


#4

Here’s a verbose output from ‘curl’:

curl -v sharingwithworld.com
* Rebuilt URL to: sharingwithworld.com/
*   Trying 2400:cb00:2048:1::6818:7214...
* TCP_NODELAY set
* Connected to sharingwithworld.com (2400:cb00:2048:1::6818:7214) port 80 (#0)
> GET / HTTP/1.1
> Host: sharingwithworld.com
> User-Agent: curl/7.54.0
> Accept: */*
> 
< HTTP/1.1 301 Moved Permanently
< Date: Sat, 25 Nov 2017 15:36:54 GMT
< Transfer-Encoding: chunked
< Connection: keep-alive
< Cache-Control: max-age=3600
< Expires: Sat, 25 Nov 2017 16:36:54 GMT
< Location: https://sharingwithworld.com/
< Server: cloudflare-nginx
< CF-RAY: 3c35afab2361984d-LAX
< 
* Connection #0 to host sharingwithworld.com left intact

#5

It is working now.


#6

@xaq @sdayman I don’t know why it’s not working on my side. Also it’s a very super slow to open…


#7

There’s always the chance that DNS is directing you to the origin address. Can you open up Dev Tools in your browser to check the HTTP response headers to see if it’s being served by Cloudflare? Have you tried visiting it from a computer? Sometimes, mobile browsers present glitches not present during a desktop session.

I’ve not tried Dev Tools in iOS, but this might work:


#8

I have checked from mobile with an update browser and it is OK. My guess is you are using an old browser which cannot handle intermediate certificates.


#9

Thanks @Xaq @sdayman now it’s working properly…


#10

4 posts were merged into an existing topic: My site not working with https for security