Status for Domain Transfer

Hi, I was transferring a few domains and for some reason, got a few errors with regards to Credit Card payment. However, 1 domain is being charged, while others failed. I have changed my payment method to PayPal and that worked better.

My question is with my first domain that went through. Doesn’t look that it is being processed. Is there a problem or is this normal?
Screenshot 2019-12-27 at 2.50.18 PM

You will need to contact support about this.

How do I contact support? Tried searching on the website, but always ended up to the Help Centre or instructions asking to sign up to Community forum :frowning:

Click on the above link will redirect me to :

Which will again redirect to the page (screenshot):

And it says

file a Cloudflare Support ticket.

Ah, got it. I did click on the “Get additional help” section earlier. A form appeared asking me to select the domain which I am having issue with. When I clicked on the domain, it brings me to the domain management page. Finally found out that I am supposed to click anywhere on the row, but NOT the domain name to select.

Thanks for your help.