Static site configuration wrangler.toml

We are trying out running a static site using workers. According to the documentation we are able to define a local dev port in the wrangler.toml file. So I have this:

[dev]
port=5500

When we run wrangler dev, the port is still set to 8787 (default). Is there something in addition I need to add to the command line for the toml file to be read?

Sorry to hear about the issues you are having with your Wrangler configuration file!

From your description it does sound a bit unexpected that your localhost is not listening on port 5500, though just to double-check that it’s not specific to this parameter, I wanted to ask:

  • Is wrangler dev respecting any of the other parameters you are passing with the .toml file?
  • Also, just to confirm – are you able to successfully pass the --port 5500 value via the CLI?

Best,
Peter

Passing --port 5500 does work as does using the --host parameter.

I am not sure if dev is reading the toml file at all. I have confirmed when I run wrangler publish it is reading the toml file.

That seems a bit unexpected;

Just to confirm one last detail here – is port 5500 presently open on localhost?

Best,
Peter

Correct, port 5500 is open on localhost. When I run wrangler dev --port 5500 the service starts listening on port 5500, not 8787.

That’s right you had mentioned that it works from the CLI when passed as parameter – apologies about that.

If you would like to open a support ticket with our team we can troubleshoot some of the specifics with you further, would this work for you?

Best,
Peter

Yes, I can do that. Thank you