Static images / files not being cached

Hey guys, hoping someone can help.

I’m having issues with static images/files not being cached on nerdsonsite co za. Started with Cloudflare 4-5 days ago and haven’t been able to resolve since.

Note, I also have WP plugin issues that are still unresolved here on ticket Wordpress plugin errors and it may or may not be related.

As far as I can tell it’s not a header issue, and enough time has passed to populate the cache.

Oddly, I’ve also tried pausing Cloudflare, changing web rules, and nothing actually has an impact on the results I get, I still get 4 cached items, 1 polish, nothing else.

Thank you in advance for any help you can give.

i’ve made progress, this may have been caused by CSP.

I’m working through a resolution and if I figure it out I’ll post an update.

nvm, started working for a hot second and then went back to not. :slight_smile:

Expanding on the webrules, they do not seem to be followed.

I have tested/adjusted what I could, and played with every setting I can find. DNS is proxied.

I just see HIT for all of you static assets:

The initial HTML is not cached by default and can be enforced to be cached by a Cache Everything rule or APO depends on. (APO is recommended, as you use Wordpress)

Firstly, thank you for taking the time to reply, second, take a quick look at two replies above :slight_smile:

I believe what you may be seeing is WPEngines native cache, as Cloudflare analytics show very little cache activity (<200kb) and Dr.Flare (Chrome Plugin) shows very little caching happening.

Sorry my fault, I just checked for the header, but didn’t realized I was redirected. No O2O problem here.

I tbh don’t know why you with APO still don’t get a HIT. I checked the headers and did not find anything wrong. I also just checked another site, I know also uses APO and saw they also are not getting a HIT in cache:

But as per the title: all static files are cached and served with a HIT, just the HTML itself is getting DYNAMIC.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.