Static Content not on cdn



Hi The gt metrix shows that most of the of the content is not on the cdn. there is no change in site performance. How to rectify this.


Before being able to take a good look (I’m on my phone) it is good to know that GTMetrix doesn’t really recognize Cloudflare as a CDN, since they look for specific URL, while Cloudflare does things differently.

My guess would be some error in the configuration of the cache-control headers or the Cloudflare dashboard. Will take a look later and will come back to you.


Hi, I have updated servers manually on gtmetrix, so its giving me following report on cdn.

Its showing that the files which are coming to website from instagram are not on cdn. Is there a way we can improvise on this. If i deactivate all the instagram pics cdn performance goes over 90. previously it was 0 as there were 10 pictures from instagram linked to webstie i reduced the number to 5 and cdn performance went up to 50.

Any comments on further improvent and improving site speed. its still giving me aroudn 9 secs to get fully loaded.


The site seems to take an incredible amount of time to reply. 2.8s it’s a lot of time!

Plus I do not see any Cloudflare headers in the requests, I am assuming you have no caching whatsoever enabled. Would you mind sharing some screenshots of the dashboard configurations?

Concluding, do not consider as gold those info, every site is different and can have different results that are still optimal.


Hi Matteo, I am using autoptimize plugin to delete cache.


I am new to website building. If there is anything required to configure of WordPress kindly let me know. Another screenshot of my plugins is as following.



I know basically nothing about Wordpress. Maybe @sdayman can help?


Ok…in the GTMetrics results you posted, the www for your domain was not going through Cloudflare, but the naked domain was. It looks like you’ve fixed this now, so you’re fully covered.

As for the initial load, I see two things:

  1. Your server is slow to redirect non-www visitors over to www. A Page Rule here would speed that up.
  2. You don’t have any page caching. Due to being a shopping site, this is difficult, but not impossible. A good Woo Commerce compatible plugin might help, but I don’t use Woo Commerce and haven’t experimented with this. WP-Rocket is highly praised and might be a good solution.

Ultimately, Cloudflare can’t speed up a slow server on a highly dynamic site. Good caching or a faster server is your best bet.


Didn’t notice that! :face_with_raised_eyebrow:


Hey sdayman and matteo i have configured cloudflare in w3 cache plugin and got better results. reduced load time by around 3 secs(for US and Canada). so i am on around 6 secs now. want to reduce 2 more secs. Thank you. If you can recheck and suggest soemthing.


The initial page load is still a little slow. It’s consistently ~750ms for me. Where is your server?

Is there a way to turn off Contact Forms 7 for the front page? I don’t think you have a form there, yet there’s a “refill” file that takes nearly 2 seconds to load.

There are also a couple of YouTube resources that load 10 seconds after the page finishes. The fastest I can get your page to load is ~2.5 seconds, excluding those calls to YouTube.

Overall page weight is ~3 megabytes. Maybe you can compress some of the larger images. Here’s a plugin that can help compress images in your library. They do 500 free file compressions per month (each image on your site might have 4 or more sized files).

I added the link. Happy now, @Matteo?


I would assume the server in the EU, since I get a 2/2.5s load time without even the cache enabled and without removing.

EDIT: confirmed, probably Amsterdam

This line, there is no here :joy:


i have removed contact form 7 on the pop up and controlled a bit ajax call so now its under 4 sec. The thumbnails in the bottom footer are causing a delay ican improve more.


yes server is in Russia


This topic was automatically closed after 31 days. New replies are no longer allowed.